I have an issue in Windows 7 where I get the following error message when attempting to access an admin network share on a machine in another domain:

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

Troubleshooting I've Done

  1. Start > Run > cmd > net use * /DELETE
  2. Start > Manage Windows Credentials > Deleted all credentials

I still receive the same error until I reboot my machine. After I reboot, it works fine. However, I am able to log into the admin share if I hit it by its IP address.


My question is, is there somewhere else I should be looking for cached user credentials?


Just reverse your troubleshooting steps:

  1. Start > Credential Manager > Windows Credentials > Remove from vault
  2. Start > Run > cmd > net use * /delete

And voila! Network shared access succeeds with a different username.


I have the same problem but with a Linux server. I first thought it was a name lookup problem - DNS clashing with NetBios - the DNS had the domain name and the NetBios the workgroup. I spent a lot of time trying to find out what was going on and I'm still not sure. But ---- I cleared the credentials (credential manager) and then set up a mapped drive but ticking the Connect using different credentials box and then entering the correct credentials. Imdediately I could browse, view and connect to the shares on the linux box - even after removing the mapped drive. However after removing the share I had to enter the user and pass again. Still not sure I've got it. mikej

  • Same problem but Windows Server 2003. Removed mapped drives and did exactly as you did, connect using "different" credentials (which were actually the same credentials) and it worked a treat. No idea why. Thanks!! – shousper Mar 26 '13 at 4:49
  • I'm not sure that removing the mapped drive totally removes the connection you've established with the drive. In other words, I don't believe that removing the map to the drive removes the actual connection information to that drive as well. Sorry I can't contribute more to your process, but food-for-thought while troubleshooting – root Oct 31 '13 at 20:29

I don't know if it's applicable, but I once had a Buffalo Tech NAS box (it ran linux under the hood). The documentation for it simply said that after joining an AD domain, the box would only be accessable via IP address. I never fought it, just was the way it was. Indeed, after joing AD I would get the error of the OP until I accessed it via IP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy