7

I have a Logitech k400 and I can't seem to find how to make it wake the computer when sleeping.

I have 2 mice and keyboards under the device drivers. One mouse and one keyboard have power options, the HID ones do not.

How do I get my wireless device to wake my Windows 7 computer?

1
  • Most likely your computer turns off it's Bluetooth radio when it's sleeping. Sep 10, 2013 at 2:45

7 Answers 7

5

Check to be sure "Allow this device to wake computer" is enabled.

From control panel click on mouse. mouse 1

In mouse properties click on the Hardware tab. Select Logitech mouse, then click properties.

mouse 3

Tick the check box "Allow this device to wake computer". Click OK

m3

This should also be available for the keyboard if it is not set to wake the computer.

Worth a check anyway.

1
  • 2
    SE approved red circles need to be free hand ;p
    – Journeyman Geek
    Sep 10, 2013 at 0:56
7

I had this problem too and I got it fixed.

  1. Go to your 'Power Options' in your control panel.
  2. To the right of your selected power type, click 'change plan settings'.
  3. Then click 'Change advanced power settings'.
  4. Scroll until you see 'USB Settings'.
  5. Then click the + sign until you see a box with 'Setting' = Enabled. and Disable it.

DONE!

5

You can check the bios (by entering the magic key combo at boot) and make sure USB Wake, or a similar sounding option, is enabled in the hardware. It's not disabled by default but I think it gets disabled for power saving reasons.

3

To have your mouse take your computer out of standby mode go to Control Panel:

  1. Performance and Maintenance
  2. System
  3. In the System Properties window click the Hardware tab.
  4. Device Manager
  5. Click on + Mouse & pointing devices.
  6. Highlight HID compliant mouse then go to top and click on Properties.
  7. Power management tab and check Allow this device.

This worked on my Windows XP.

2

just being a helpful googler here with a suggestion for those who are in the same boat as I was. For some reason, the wireless mouse plugged into USB 3.0 ports weren't waking up my computer. The USB 2.0 ports worked, however. Try moving your mouse receiver into a USB 2.0 port.

0
1

This could also be caused by your motherboard and/or BIOS configuration. This article explains step-by-step how to check if your motherboard USB "jumpers" are enabled, and how to enable the wake up event in your BIOS. It's specific to an MSI motherboard, but the principle is basically the same no matter what kind of hardware you have.

0

Waking from wireless USB mouse/keyboard didn't work for me on Windows 7 or Windows 10. I started using my network device to wake up the computer. I installed free Mocha Ping Lite app on my iphone "https://itunes.apple.com/us/app/network-ping-lite/id289967115?mt=8" and then ping the IP address of my laptop to wake it up.

1
  • 1
    While this is an alternative to the issue it isn't an answer to the question, this would be better suited as a comment. Please try to add in a solution to keeping the Bluetooth adapter powered on when the system sleeps and this would be more fitting.
    – Abraxas
    Feb 20, 2016 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.