23

Not a duplication of Disable [Windows]+[Space] hotkey in Windows 8

The question and answers in the link above talked about removing the input methods to stop switching of the methods. I differ because I want to KEEP the input methods. But remove/disable/prevent the [Windows]+[Space] hotkey for toggling them.

I have two Inputs Methods. (Two keyboard layouts in fact), The Standard UK layout, and created a second keyboard layout, I have called it ABC Layout, but its actually just a bunch extra symbols like copyright and a large number of other such symbols.

There is a Hotkey in windows 8.. Its [Windows]+[Space].. I would like to disable this. This hotkey toggles between the two Inputs.. Sounds convenient, but it really is not. I don't know how or when, but it seems I sometimes hit this Hotkey without wanting to and end up with all sorts of gack on the screen if I am reading something off a second screen/paper.

I have gone into the logical location in the settings that deal with input and language control and the Hotkeys that deal with them. As you can see in the picture I had supplied, I have already removed the Hotkey for toggling [Please see image below], but Pressing [Windows]+[Space] still toggles the Input Mode.

No Hotkey

It seems in Win8, they have these options, but then just ignore them and do whatever it wants anyway as I have ALSO set language bar to be Hidden. But as you can clearly see in the screenshot, it's still there.

Hidden Selected Still Showing

  • @Ramhound: I have re-ordered the question, Kinda did a mismash between my edits and original message. I also added a brief explanation of why. I didn't originally add this because I have been downvoted before on StackOverflow for it being irrelevant but maybe SuperUser prefer it. We will see. – WORMSS Aug 15 '13 at 15:40
  • 1
    @WORMSS Don't take Ramhound too seriously. I'm not sure what his problem is, exactly, but there's definitely something going on there that's not worth getting too close to. – Aaron Miller Aug 15 '13 at 15:47
  • 1
    @Firee I've listed the reason in my question already. – WORMSS Feb 4 '14 at 14:38
  • 1
    I have my input methods Dvorak and QWERTY layout and this gets switched accidentally far too often if Windows+Space is active. This didn't use to be the case in Windows 7. Windows 8.x introduces far too many annoyances such as this and really really sucks – andz Mar 11 '14 at 20:44
  • 1
    By that logic, I could get rid of the problem by uninstalling Windows.. I need the second keyboard layout. (Hence why I have two in the first place). And it seems you have 2 languages, rather than 2 keyboard layouts for the same language. So not 'identical case'. – WORMSS Aug 19 '15 at 9:32
5

It doesn't seem like there's a natural way to do this from within Windows 8, but you can do it using AutoHotkey. Download and run/install AutoHotKey, right click on some folder, then New>AutoHotKey Script. Edit that with Notepad or Notepad++ and add this hotkey:

#Space::
return

That remaps the Win(#)+Space(Space) button to do nothing. Then you just run the AutoHotkey Script. To get it to run automatically when your computer starts, put the script into the startup folder.

Hopefully autohotkey isn't too intrusive. Maybe you'll find some other uses for it (I think I first found out about it when I was trying to remap Caps-Lock so that it doesn't do anything, since that's the world's most pointless key).

  • Was reluctant to install this just for this situation, but feels so but better now not accidentally switching language. The only reason I installed language packs was for different TTS voices and it was driving me crazy when I ended up with the wrong language all the time. – Simon Nov 3 '16 at 22:30
0

You can disable the windows + shortcut keys multiple ways:

Over windows registry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoWinKeys"=dword:00000001

In group policy editor (gpedit.msc):

User Configuration -> Administrative Templates -> Windows Components -> Windows Explorer -> Turn off Windows + X hotkeys

And you also can disable the windows key completely with Widnows Scancode Map feature. To do it, i recommend to download an open source application called SharpKeys.

You can add new keymap, type the key (press win button), and select Turn Key Off option (see the picture bellow).

sharpkeys win button remap

Press write to registry button, and restart windows.

  • 2
    This seems like it turns off ALL [Win]+Key shortcuts. Not just a single one? So I couldn't do the useful [Win]+L to logout. – WORMSS Mar 15 '17 at 10:08
  • Yes, the solution above turn off ALL [Win]+Key based hotkeys. After that, the hotkeys function accessible only over UI, or custom shortcuts. For example my lock screen shortcut based on this command: rundll32.exe user32.dll,LockWorkStation – voji Mar 16 '17 at 10:46
  • 3
    So you are saying.. for the 50 odd windows shortcuts that exist.. Turn them ALL off, and then Hack the 49 others back in? – WORMSS Mar 16 '17 at 11:45
  • All of my home computers built for special purposes (music making, gaming) the win key disabled completely. I never use any win hotkey on these computers, and the accidentally keyboard layout changes (win+space) always can create some mess. On my laptop (used during daily work in enterprise environment) i leave the win key on, because i frequently change keyboard layout, and lock the screen. I think, it's purely personal preference. – voji Mar 17 '17 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.