I am using Windows 7 RTM x64.

From Control Panel > Devices and Printers, I have three printers listed; Fax, XPS Writer, and a Lexmark.

I can print a test page through the printer properties with no problem.

I can print a text file from Notepad with no problem.

I can't print from Safari. When I press Ctrl+P, it displays the Print dialog, press OK and nothing happened.

I can't print from Adobe Reader. When I press Ctrl+P, it complains that it there is no printer installed.

I can't print from Office applications. When I press Ctrl+P, it crashes immediately. Running Office Diagnostics does not help.

I can't print from IE8. When I press Ctrl+P, it displays the Print dialog, complains that I have to select a printer from the list, selected any of the three printers, the Print button is disabled.

Any help?

Update (01/11/2009):

The default printer is the Lexmark. I'm testing on this one as well. I was about to reinstall Office (as this is the first application that has the problem), but then I tried other, some behave similarly but not identical (maybe caused by different printing implementation). On those applications that is able to display printer selection dialog, I tried the Lexmark and XPS. Neither printed anything (paper for Lexmark, file for XPS).

Update (01/12/2009):

It seems that my Windows installation is botched. A colleague have similar hardware/software combination (it's the same workstation model and Windows 7 x64) and his can print perfectly fine. I tried adding the printer from his share, no joy. I can test print from the printer property, I can print from Notepad, but not from any other application.


I had the problem when a 3rd part firewall (Online Armour) blocked things from printing in any application with the same "no default printer installed" message. Fix was a quick allow/trust setting change for the needed service that while showed running, was blocked by the program, even when it wasn't active and running :O


I had this problem in Vista, somehow windows decides to remove the "default" setting and you're left with no default. The solution is to make a default printer, then your problems should go away. Unfortunately, I don't have a fix to the actual problem of Windows removing the "default" flag. Some programs don't assume anything about printers, others assume that if there is no default, no printers are installed. Interesting case study in software design decisions though:)

  • Unfortunately, there exists the default printer. I will try to unset and set the default printer. – Adrian Godong Nov 1 '09 at 18:56

this is a simple problem that I also have had.

The solution is simple, the printer spoiler service is probably stopped, therefore you just have to start it.

Press Ctrl+ALT+Delete and open up task manager. Once you are there click on the services tap. Right-bottom of the task manager tap is a button saying 'services...' just click on that. Now a different application will open up with a list of all the services whether they are running or not. Over here search for 'printer spoiler' or a similar name that consists of the name 'printer'. Right-click on the service and press start. If you can't press start: right-click on the service and go to properties over there turn on the function that tells it start up automatically, now you will be able to start up the process. That's basically the problem that I have been having and is solved through this :D

I hope that I helped :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.