I have bought a 4GB memory upgrade (2x 2GB PC2-5300 SODIMM) for my Acer Aspire 5102WLMi (Aspire 5100 Series) laptop, I installed the two memory modules correctly however with 4GB installed the laptop refuses to POST. I have tried the following:

  • Tried both 2GB SODIMMs without the other (Worked Fine)
  • Tried the original 512MB SODIMMs (Worked Fine)
  • Tried with original 512MB SODIMM and new 2GB SODIMM (Worked Fine)
  • Tried swapping over the 2GB SODIMs (Didn't Boot)
  • Left the computer for 10 minutes with both 2GB SODIMMs installed (Didn't Boot)
  • Checked latest BIOS installed (No Change)

The Crucial website said that the laptop supported 4GB of RAM as do several other sites through found through Google, up until now I was fairly confident this would work.

Couple of questions that would be good to have answered:

  1. Question: Has anyone got an Acer Aspire 5100 Series running with 4GB RAM?
    Answer: Yes, I have now got one working with 3.75GB Usable, the rest is occupied utilized by the Graphics Card.
  2. Question: Any tips on getting this to work; is there a CMOS reset switch?
    Answer: Yes there is, if both SODIMMs are removed two very small interlocking PCB tracks are revealed. If these are shorted together with a screwdriver the BIOS will be reset.


  • 1
    What version of BIOS do you currently have installed? If a newer version is available, try updating. – Ben S Oct 30 '09 at 18:42
  • requires DDR2 PC2-5300 memory – Molly7244 Oct 30 '09 at 18:53
  • I had a 5102WLMi which I was able to successfully upgrade to 2GB. Never got farther, though, because it later decided to refuse to boot Windows (not related to memory, it was something on the mb itself). – NickAldwin Oct 30 '09 at 19:00
  • Will it boot with mismatch sticks installed? Meaning try installing one 2Gb and and one 512 together. – Matt Oct 30 '09 at 19:29
  • @Molly PC2-3500 was a typographical error it is indeed PC2-5300 that was taken out, and replaced with 2x 2GB SODIMs. – Richard Slater Oct 30 '09 at 20:07

The solution in the end was to reset the BIOS, there is a small jumper located beneath the SODIMM slots labelled J2. After removing the battery, I shorted this with a screwdriver; after putting the laptop back together it booted up with a warning the the CMOS memory was invalid. Set the BIOS up again as per my preferences and now I have my 5102WLMi working with 4GB of RAM.

Acer Aspire 5102WLMI with 4GB DDR 2 RAM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.