I've bought a new hdd for my machine and installed ubuntu on it. I wanted to copy some of my files to the new hdd from the old one which was previously my primary hdd so I used fdisk -l to get the partition list, yet it displayed only GPT, so I've tried to mount it but the only thing that was there was <mount folder>/EFI/ubuntu/grubx64.efi. I couldn't find anything resembling the / folder. So how can i transfer some of my files from my old hdd to the new one?
UPD: Problem was resolved by reading this article, and using vgchange -a y [VGName] if LV status was 'NOT available'

closed as unclear what you're asking by nerdwaller, bwDraco, Mokubai, mpy, Shekhar Aug 19 '13 at 20:11

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Your question is very confusing, fdisk cannot show GPT disks so that isn't a surprise. But what is confusing is you then say "so I've tried to mount it", mount which, to where, and how? And then on what you tried to mount was only the /EFI/*? What do you mean you can't find anything resembling the / folder, what does it mean to resemble a / folder? – nerdwaller Aug 15 '13 at 22:05

What is your old disk device name? use parted for gpt disks to find out its partition.

sudo parted /dev/sdb print

then mount the appropriate partition. You may have mounted the wrong object based on erroneous display from fdisk, I think. So you need to make sure that the correct partition is mounted in the first place.

Also, what is your mount command, and what does the following command show?

sudo mount
  • Why is this an answer? These look like things that all belong in comments to me. – nerdwaller Aug 15 '13 at 22:06
  • Thanks. I added some clarification. I think it answers the question why files were not found -> incorrect partition or rather device was mounted because fdisk cannot correctly identify the partitions of a gpt disk. – johnshen64 Aug 15 '13 at 22:11
  • sudo mount gives this link sudo parted /dev/sdb print returns link As I suppose the last partition in what parted printed me is the one I need. – Tsukihime Aug 15 '13 at 22:28
  • yes, the last one, but that is an lvm partition, so you need to use lvm commands such as lvdisplay to find logical volumes to mount,not partitions. – johnshen64 Aug 16 '13 at 12:03

Use gdisk to list partitions for GPT disks.

gdisk -l /dev/sdb

Another useful command to determine partitions (provided they are labelled)


Use GParted to view all drive partitions

sudo apt-get install gparted
sudo gparted

For GPT+UEFI bootable disks, partition 1 is a FAT32 "ESP" partition which is what you were seeing. The root filesystem for your old drive is probably on /dev/sdb2

Not the answer you're looking for? Browse other questions tagged or ask your own question.