I am trying to follow the directions in Can Windows 7 Task scheduler start a playlist in Windows Media Player 11?, but it is not working for me.

It may be because

  • I want to play video rather than audio, or because
  • I want the computer to wake from Sleep mode to run the task.

I set up a Windows Task Scheduler task by following all of the instructions in the answer to that question (https://superuser.com/a/479426/219755) and also checking the box "Wake the computer to run this task" (under the "Conditions" tab in the settings for the task once entered).

The problem is that my computer does wake from sleep, but the screen does not turn on. If I move the mouse pointer the screen turns on, but shows me a log-in screen. Again I am not sure what the problem is.

  1. It might be just the computer failing to log in, but
  2. it might (also) be the computer not turning on the screen without user input.

I have read task scheduler won't wake the computer, but unlike in that question it does look like my computer is waking. It is just not doing the right things after waking.

I think issue "1." above has to do with the task scheduler "Security options":

  • ( ) Run only when user is logged on
  • ( ) Run whether user is logged on or not
    • [ ] Do not store password. The task will only have access to local computer resources.
  • ( ) Run with highest privileges

...but I have tried different choices there and not been able to get this to work.

Does anybody know how to use Windows Task Scheduler to wake from sleep and do any task with the screen on?

(I assume a method that works for anything like that would work for playing a video.)

3 Answers 3


Go to Control Panel Users and set the option so Control-Alt-Delete isn't required. Look at your BIOS settings for various power saving sleep states and play with those. S1 S3 S5 and all that. In Device Manager for your video card see if there are power/wake options. I know this isn't an answer, but it's a few things I'd try. - Joe

  • It actually turned out to be a different fix for me, but +1 for these suggestions, which might work for future readers. :)
    – A.M.
    Aug 17, 2013 at 15:28

What ended up working for me was disabling Windows presenting the lock screen upon waking from Sleep mode (or Hibernate mode, I imagine).

I found the instructions here: http://www.pha-tech.com/resources/computer/other_win_tutorial/How_to_Enable_or_Disable_Lock_Screen_after_Waking_Windows.php

In short, though it's:

  • Start
    • Control Panel
      • Hardware and Sound
        • Power Options
          • <'Require a password on wake-up'>
            • ( ) Do not require a password

Yes, this setting is improperly named. It actually suppresses the lock screen rather than simply not requiring a password to pass it. (I actually had no password on the user account to begin with, but changing this setting did make a difference and make the waking for the scheduled task work.)

It seems like there should be a better way, so if anyone posts one (which deals with the lock screen properly instead of disabling it altogether), I will change my accepted answer to that!

  • I think most of the information needed for a tidier solution are here: social.technet.microsoft.com/Forums/windowsserver/en-US/… ...but my version of Windows seems to be missing the setting menus talked about there ("secpol.msc /s"? "Group Policy Editor"? "Default Domain Policy"?). If that's the case, I would change my accepted answer to an answer that replicates the settings changes talked about there with registry changes.
    – A.M.
    Aug 17, 2013 at 16:08
  • ...or of course any other solution that works without disabling the lock screen, but is more lightweight than messing with the registry!
    – A.M.
    Aug 17, 2013 at 16:14

If the task wakes up the computer but gets stuck in the login screen use the group policy to add your username into this:

Computer Configuration-->Policies-->Windows Settings-->Security Settings-->Local Policies-->User Rights Assignment--> allow logon locally

Actually, the task does not need to be logged to work. Simply uncheck the task the option "run whether the user is logged or not". The task will just do whatever you will ask (eg. play a sound using WMP) behind the logging screen. (If you really need to log on edit the group policies).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .