Since I was formatting my PC I noticed, when downloading network drivers, that the BIOS for my motherboard (ASUS P8H67-M) was changed significantly since last I updated it.

So I went ahead and downloaded the latest BIOS for this motherboard, and proceeded to install the BIOS during one of the many system restarts needed when setting up a system from scratch.

The update was going well - the update utility recognized the BIOS file and accepted it. At the end, a message that a reboot is required appeared with an OK button.

And here's where things went sour. Pressing enter, the system would proceed to beep wildly with short beeps until I eventually turned the system off (long press of the power button). Now the system is quiet - the fans would spin, but it's as if the CPU was missing.

I tried to clear the CMOS, both using regular means as well as popping out the battery and disconnecting all power. I even detached the memory sticks to see if the system would complain about that (it should beep in a specific fashion when no memory is in the system). Alas - nothing. No beeps, no video signal - only the silent hum of the CPU and PU fans.

I'm a bit baffled by the experience - how is this possible? Did I flash the wrong BIOS? If so, don't these systems check if the model is OK and prevent flashing the wrong thing? I'm having things strange feeling where I feel I did something wrong but at the same time feel I did everything right.

Also, what can I do now?

4 Answers 4


Unfortunately the CrashFree utility (mentioned by Brian) turned out to be a big bust and was pretty much useless. The whole motherboard was basically bricked.

I had to send it for repair. When I got it back, the note said that "no repairs were needed, only a new BIOS had to be installed" - I'm guessing the service team has a way to hook up the motherboard to flash a new BIOS directly - possibly via the little removable chip.

Anyway, I also think I know what the reason for this was. As Keltari mentioned in one of the comments in the other answer, doing small increment upgrades on a "sister PC" (with the same motherboard) worked fine. What wasn't apparent before was that one of the BIOS updates was pretty large and required a dual-flashing procedure. My guess is that when I originally installed the latest BIOS on a very old BIOS, skipping this step, I bricked the whole motherboard.

So there - I'm posting this answer as it contains the most likely reason and the only repair procedure I could use.


Read the manual, section, 2.1.3 ASUS CrashFree BIOS 3 utility.

Basically you put a BIOS on a flash drive or insert the support DVD and then boot.

Note: Remove extra USB hard or flash drives as at least some ASUS BIOS get confused with ExFAT drives and then can't find the FAT32 drive with the BIOS file on it. Keeping an old USB flash drive around for this purpose works well (I use an old 256mb thumbdrive).

  • if you find you are still having issues, dont go to the latest version of the BIOS, go up in small increments.
    – Keltari
    Aug 16, 2013 at 14:02
  • With high hopes I did as you suggested. I've downloaded the old BIOS that I remember working before this little disaster and placed it on a freshly FAT32 formatter flash drive, renaming it according to the instructions (P8H67-M.ROM). However, the system is completely silent when I turn it on, except for the turning of the fans. The screen is blank, and even the light on the flash drive doesn't blink (which would indicate it's in use). It's a larger drive than the one you mentioned, but FAT32 formatted anyway. I have a feeling the failed update may have screwed up the BIOS completely. :(
    – Shaamaan
    Aug 16, 2013 at 14:29
  • Try the MemOK! button, odd that memory would end up with bad timings from a BIOS update but worth a try. Also look at the C.P.R. (CPU Parameter Recall) feature - BIOS settings should revert to safe settings after a failed boot or two.
    – Brian
    Aug 16, 2013 at 14:33
  • The MemOK! button did nothing. You do realize the system is silent? There's no video on either output (HDMI/analogue), not even the initial system beep when the system starts up? Anyway, I've already tried cleaning out the CMOS (it was actually thing first thing I tried, albeit I forgot to mention it in my question - I'll add that now).
    – Shaamaan
    Aug 16, 2013 at 14:45
  • 1
    The CrashFree feature is supposed to be a bit of pre-regular BIOS safeguard that lets you recover from most failed BIOS updates. It can fail to detect depending on other USB devices however. Even see some that had to use a PS2 keyboard and unplug the USB one. A smaller flash drive can sometimes be more successful as well.
    – Brian
    Aug 16, 2013 at 18:09

I had the problem upgrading a P8H67 from version 0803 to latest 3801. I had to reflash the same version of BIOS to fix it.

If you never see a graphic UI (ie boot loop), try with another graphic card.

Here i had the bootloop with a radeon X1600 Pro but was ok with a Geforce 9600.

The Error message on boot was a graphical message box saying "Reading Failed"

And plug a USB KEY with the BIOS unzipped in the USB 2 Port (not USB 3)


I had a similar issue with my new Asus MB. Black screen, no EX Bios operation etc. The one thing no one said to do was to short the clear CMOS jumper. After I did that, PC Posted.

  • 1
    I tried to clear the CMOS, both using regular means as well as popping out the battery and disconnecting all power. So, no, that's not a solution. I mean, great that this helped you, but in the case described above I've already tried cleaning the CMOS.
    – Shaamaan
    Nov 12, 2020 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.