Western Digital My Book Live 2TB NAS device - Firmware 02.42.03-027

NAS connected using Cat 5 ethernet cable to a Cisco E2500 router.

Machine A - Windows Server 2003 with a wired connection to the router

Machine B - Windows 7 Home Premium 64-bit laptop with a wifi connection to the router

Router is dual-band, both bands using the same SSID, mixed mode (b/g/n).

From (A), I was able to transfer many GBs of data over to the MBL with no issues, flawless performance.

From (B), when I access the MBL drive with a drive mapping (X:) to \mbl\share, it crawls at a extremely slow speed. Simple JPG photos ~5MB take forever to open, even timeout sometimes. Windows Explorer shows the green progress bar at the top showing the file is loading.

This led me to believe that this is a network issue. But when I access a network share on (A) from the same laptop (B), it is blazing fast. I am not sure what component is the bottleneck here. It is almost as if the MBL throughput is throttled only when it is accessed via wireless client but it pushes out the content just fine to a wired client.

Some more observations:

  1. I used the http://www.totusoft.com/lanspeed.html utility to run diagnostics from Machine (B) to Machine (A) and the My Book Live. Both of them did well, with a read/write throughput of around 55Mbits/s.

  2. The NAS device starts off fine, I am able to open/close a dozen or so files rapidly. Then it starts to crawl really badly. Speed plummets. As if some cache is being exhausted or something.

  3. I read somewhere that Windows Explorer might be the issue here. So I downloaded an alternative explorer (Explorer++) and (maybe due to the placebo effect), it seemed like things were flying, I was able to browse/slideshow dozens of JPG files but then the dreaded "Not Responding" came back and Explorer++ also froze up.

  4. I turned off the thumbnail folder option in Explorer and used the "Details" and even the "List" view. In all the cases, it seemed to improve performance for a few minutes but then it started to crawl again. Again, it almost seems as if either the Windows 7 machine or the NAS device is asking for a "timeout" to catch its breath and then it is fine for a while :-)

  5. All other clients (mobile devices both iOS and Android) are able to access the NAS just fine using the WD2go app.

Anyone else seen this issue? How should I go about troubleshooting this? Are there any settings I can tweak to improve the performance? It is almost as if Windows 7 simply doesn't perform very well when accessing a NAS share.

Any suggestions appreciated. Thanks.


Finally got to the bottom of this. The magic setting that solved my problem turned out to be adding

smb ports = 139

to the smb.conf file on the WD My Book Live NAS device (after ssh'ing into the device)

The default for this parameter is ports 139 (NetBIOS) and 445 (TCP). Not sure why the default value was causing such a severe performance degradation for file transfers and browsing but my guess is that the Windows 7 client was trying port 445 first, somehow losing the connection and was downgrading to port 139 and was unable to reconnect.

Hope this helps someone else.


Here are some settings might have an impact on what you are reporting.

Something to consider is the MTU size or what are called Jumbo Frames. Hardwired full-duplex is another thing you might want to look at.

Changing the MTU size is part art and part science. Drivers in FreeBSD, Linux and Windows are unreliable in what sizes are allowed. You may have to dig into the driver documentation or experiment to get the sizes that are acceptable. Also, lowest value is the default for the entire path.

On windows right-click the NIC in device manager and look in the properties of the NIC driver. MTU or Jumbo Frame or Framesize may be the name of the setting for your driver. The default value is usually 1500.

Some notes will mentioned hardwiring full-duplex but any modern switch will deal with this quickly and not be a problem. I did not see any issues with duplexing on modern hardware.

  • I tried changing the MTU (1500) to 1000 and 9000 using netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1458 store=persistent and that didn't seem to make much of a difference. This is getting to be frustrating. Any other ideas? Thanks – partlycloudy Sep 10 '13 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.