0

I'm certain this used to work (some months ago), but I can not get WODIM to burn a DVD from an ISO image.

I know that my DVD drive is working, and that the device assigned to it is /dev/sr0 (I know its /dev/sr0 because "eject /dev/sr0" works)

When I try and burn an iso using the command "wodim dev=/dev/sr0 -v image1.iso" I get the following result:

root@folio:/lib/modules# wodim dev=/dev/sr0 -v image1.iso  
wodim: No write mode specified.
wodim: Assuming -tao mode.
wodim: Future versions of wodim may have different drive dependent defaults.
TOC Type: 1 = CD-ROM
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
wodim: Success. 
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.

(If I use the command wodim dev=/dev/sr0 -dao -v image1.iso I get the same result minus the -tao message)

wodim --devices shows nothing (Just to lines of ----)

wodim -scanbus shows

scsibus0:
    0,0,0     0) 'ATA     ' 'SAMSUNG MZMPA128' 'AXM1' Disk
    0,1,0     1) *
    0,2,0     2) *
    0,3,0     3) *
    0,4,0     4) *
    0,5,0     5) *
    0,6,0     6) *
    0,7,0     7) *
scsibus6:
    6,0,0   600) 'Generic-' 'xD/SD/M.S.      ' '1.00' Removable Disk
    6,1,0   601) *
    6,2,0   602) *
    6,3,0   603) *
    6,4,0   604) *
    6,5,0   605) *
    6,6,0   606) *
    6,7,0   607) *

The ATA device is my SSD disk. I'd imagine that device 6,0,0 represents my SD card reader (built into the PC). nevertheless I tried to burn using dev=6,0,0 and it did not work - not a surprise really.

I am running the following kernel - Linux folio 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

When I unplug and plug in the disk (and then try a burn with WODIM which fails), syslog shows

[3709678.451109] usb 2-1.2: USB disconnect, device number 89
[3709687.901218] usb 2-1.2: new high-speed USB device number 90 using ehci_hcd
[3709688.002048] scsi2691 : usb-storage 2-1.2:1.0
[3709689.004370] scsi 2691:0:0:0: CD-ROM            TSSTcorp CDDVDW SE-208AB  TS00 PQ: 0 ANSI: 0
[3709689.035744] sr0: scsi3-mmc drive: 62x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[3709689.036166] sr 2691:0:0:0: Attached scsi CD-ROM sr0
[3709689.036675] sr 2691:0:0:0: Attached scsi generic sg2 type 5
[3710909.678527] UDF-fs: Partition marked readonly; forcing readonly mount
[3710909.755672] UDF-fs: INFO Mounting volume 'UDF Volume', timestamp 2011/04/12 21:38 (12d0)
[3711084.994284] usb 2-1.2: USB disconnect, device number 90
[3711090.919294] usb 2-1.2: new high-speed USB device number 91 using ehci_hcd
[3711091.044646] scsi2692 : usb-storage 2-1.2:1.0
[3711092.046229] scsi 2692:0:0:0: CD-ROM            TSSTcorp CDDVDW SE-208AB  TS00 PQ: 0 ANSI: 0
[3711092.079436] sr0: scsi3-mmc drive: 62x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[3711092.079910] sr 2692:0:0:0: Attached scsi CD-ROM sr0
[3711092.081155] sr 2692:0:0:0: Attached scsi generic sg2 type 5

When I put a disk in the drive udev typically does its thing, ie it mounts a disk with data, and pops up a screen (which I can't use, it does not offer a burn a disk option)

Anyone have any pointers to why this is not working ?

2

I know this reply is a little late, but I think I figured out why you had to reboot to make this work. According to this Super User post, getting a Cannot open SCSI driver error message from Wodim is most likely due to the disc you are trying to write to being mounted. Above, you described udev doing "its thing", mounting the disc you intended to burn. As the question I referenced above indicates, Wodim needs exclusive access to the optical disc writer, and because the kernel holds the optical disc writer device open (that's how a file system is mounted), Wodim cannot continue. When you reboot, however, most Linux systems do not auto-mount removable media which has been present in the system since before the system was rebooted; they will recognize such media, but they will not mount the media unless explicitly instructed to. Most desktop environments have an option to eject optical discs (ejecting an optical disc implicitly unmounts the disc as well), but do not use this option, because when you re-insert the disc, the auto-mounter will re-mount the disc and start the whole loop over again.

So, the only sure way (that I know of) to unmount the disc without rebooting is to use the umount command. You do not generally need superuser privileges to unmount a disc that was auto-mounted while you were logged in; in most cases, you can just run from the command line:

umount /dev/sr0

...assuming that your optical disc writer is indeed named /dev/sr0.

| improve this answer | |
0

I managed to get this working in the end.

I did an apt-get upgrade, which installed a substantial amount of new code (downloaded about 350 megs), but this did not make a difference, and wodim did not perform any differently.

Although the kernel did not change, I rebooted the machine and tried again and I was able to burn the disks without issue. I suspect that somewhere along the way a driver got confused, and rebooting fixed the issue. (Its a bit embarrassing to need to reboot a Linux box though !)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.