I have DD-WRT running in gateway mode on a DIR-615 I1. I've updated to the newest available build.

Chromecast is a wireless-only device, for those unfamiliar. The device has been set up and operates normally using wireless devices associated with the router, but wired ethernet devices cannot communicate with Chromecast. Specifically, the Chrome plugin says "No Cast Devices Found."

AP Isolation is disabled.

I have sniffed packets between a laptop via both wired and wireless connections and Chromecast, and this is what I've found:

There are IGMP, TCP, UDP packets between Chromecast and a wireless interface on the laptop.

There are IGMP and TCP, but zero UDP packets exchanged between Chromecast and a wired ethernet interface on the same laptop.

Specifically, the wired interface does receive the following IGMP packet from the Chromecast:

1062    55.011807 IGMP    60  V2 Membership Report / Join group

... which is also observable on the wireless interface. Some packets on the wired ethernet interface are marked as having a bad ipv4 header checksum (0x0000), but I've read this is artifactual due to checksum offloading on the NIC.

Here is the (redacted) TCP stream observable on the wired interface:

GET /ssdp/device-desc.xml HTTP/1.1
Connection: keep-alive
Cache-Control: max-age=0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.49 Safari/537.36
DNT: 1
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,en;q=0.8,fr;q=0.6

HTTP/1.1 200 OK
Content-Type: application/xml
Content-Length: 1078

<?xml version="1.0"?>
<root xmlns="urn:schemas-upnp-org:device-1-0">
    <friendlyName>Bedroom TV</friendlyName>
    <manufacturer>Google Inc.</manufacturer>
    <modelName>Eureka Dongle</modelName>

This is apparently not good enough for function, and the lack of UDP packets going in the ath0 --> eth1 (the WLAN and LAN interfaces on the DD-WRT router) direction is suspicious. Can anyone shed light on what may be happening? Bridge and route settings on the DD-WRT are all basically default.

  • Try changing your channel? ive read some people having trouble with chromecast on ddwrt i use channel 11 on my ddwrt setup and my chromecast seems to never have issues. trying to throw some ideas in. – NetworkKingPin Feb 2 '16 at 11:58
  • This isn’t about UDP. It’s about multicast. Sadly, multicast is still somewhat problematic with WiFi networks today. – Daniel B Feb 16 '17 at 8:03

Just had an issue with this. Other reports have said disabling NAT, connecting Chromecast and then re-enabling works.

To do this go to setup > advanced routing > operatng mode and change to router mode, then connect chromecast and then switch back to gateway.

Not sure why this works, but did for me.

  • Thanks for the suggestion. Tried it... no change. – victoid Jan 2 '14 at 5:11

Had the same issue. I was already operating in router mode (I'm using the DD-WRT box as a WAP only), so the above didn't apply. Try enabling IPv6 support in the DD-WRT firmware.

 Administration --> Management Tab
      IPv6 Support... IPv6 -> enable

Some devices using DD-WRT out there require this for Chomecast to function correctly. Worked for me.

My setup:

Cisco SG300-10 > Gateway Router
Wired PC
  • 1
    Thanks for the suggestion. IPv6 isn't apparently available with any of the DIR-615 builds, perhaps due to space constraints. There seems to be some info on getting it running, but it looks like a lot of work. My guess for why this works is that you're simply bypassing whatever routing is broken in IPv4. – victoid Jan 2 '14 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.