27

I have bookmarked some sites with titles "Free mp3 song", "Free video" and so on.

When I am searching for "Free " in address bar, the bookmarked sites are shown first. How can I hide the bookmarked sites from showing in address bar?

9
  • 4
    Aside from simply renaming them? Oct 7, 2013 at 12:44
  • 2
    This just isn't possible. Google has stated it will never be an option. Oct 7, 2013 at 20:58
  • 3
    @avirk All my bookmarks are arranged in folders. it is not a solution. Oct 8, 2013 at 5:52
  • 2
    Not a real solution but Firefox has an option to stop bookmarks from being suggested when typing in the address bar. And you can import bookmarks from firefox to chrome. Most chrome apps and extensions have a counterpart for firefox. But I don't recommend migrating to another browser for something you can ignore. Oct 9, 2013 at 11:47
  • 1
    I have exported and then deleted all bookmarks that I want to remain private
    – barlop
    Sep 15, 2018 at 10:36

10 Answers 10

22
+25

The Problem

The Chrome devs have stated this will never be an option.

The same as the reason we don't add options for most other things. It increases UI and code complexity, testing load, and general maintenance costs. In the case of the omnibox the whole system is designed around inline autocompletion and would require a serious rework to support an off-by-default option.

Comment 1 stands. We intend to fix problems on a case-by-case basis. We don't intend to ever provide an option to disable autocompletion.


Chrome's Omnibar has an heuristic algorithm that learns from your actions, so if you repeatedly type "h" and select the third suggestion from the browser history, it will increase its ranking. Bookmarks are supposed to be the most interesting pages from your browser history, so it's obvious that you'll find them in the list of suggestions. For now, there's no option to disable the suggestions from the browser history and your bookmarks.

I'd even hazard that Google is a bit too in love with their own product

Options

You can try replacing Chrome's Omnibar with Fauxbar. Fauxbar appears to have better control of search suggestions among other things.

Is Fauxbar for me?

  • When using Chrome's Omnibox, have you ever typed in part of a page title or address you know you've been to, yet no relevant results appear?
  • Do you find the Omnibox's mix of search suggestions, website suggestions, bookmarks and history items (or lack thereof) confusing?
  • Do you like having the option to click to use a search engine, instead of typing its name to use it?
  • Are you not using Chrome because you can't stand its Omnibox?

If you answered yes, then Fauxbar is for you.

Here's a look at Fauxbar's suggestion settings:

Fauxbar Settings

A note: Fauxbar doesn't actually replace Omnibar. It replaces the new tab page in Chrome and grabs the focus from the Omnibar upon opening a new tab.

Disclaimer: I'm in no way affiliated with Fauxbar. It's just a suggestion I've found on multiple sites that could work.

As it stands, I'm surprised there aren't more Omnibar replacements out there. I imagine it would be difficult to actually replace the Omnibar physically, but options such as Fauxbar do seem like a good alternative. I'd love to know if there are any further options available.

2
  • 4
    The "official" reason sounds like a bunch of nonsense. I think, like you said, they just love their perfect product so much that they want to force it onto every user, whether they like it or not. Jan 28, 2017 at 22:58
  • You misunderstood what google said will never be possible. They will never completely remove autosuggestions. Question is how to remove bookmark titles from suggestions. Feb 22, 2021 at 16:05
5

An easy fix would be to:

Settings

Locate people

Click add person

and browse with that account when you are in the company where you do not wish to disclose personal bookmarks.

When you open their Chrome, they will have no bookmarks that relate to your original Chrome account and you can still open the original Chrome account with all your bookmarks in place.

I would highly recommend this to be the answer, above the original best answer this is the most efficient way of dealing with the situation without having to download software or mess around with things.

5
  • the problem is chrome also takes suggestions based on who you are logged in as, so you can create a new user with no history, then log in from a certain email account and searches come up associated with that email account, chrome is that bad.
    – barlop
    Sep 15, 2018 at 10:02
  • @barlop - are you sure you didn’t associate that email account with a google account? What exactly do you mean by “log in from a certain email account “? Also, check whether syncing between devices is on. This isn’t magic: if you now have a search history, then you are no longer in that new empty google account. Feb 22, 2021 at 15:45
  • @ToolmakerSteve In retrospect, I think what I saw then was a Google.com issue, rather than a Chrome issue. But at one time, you had Gmail , and you had Google Search and they were very separate things. There was no "logging in" with Google Search. Then at some point they added a logging in, to google.com and the account became not just a Gmail account but a Google account that stored your searches.
    – barlop
    Feb 22, 2021 at 15:59
  • @barlop - I see what you are saying. Now it is necessary to log out of google account, if don’t want that history. A downside to the integration of everything. Feb 22, 2021 at 16:08
  • @ToolmakerSteve yes I know re that logging out logs out of both.
    – barlop
    Feb 22, 2021 at 16:13
3

I think I may have found one answer. Bookmarks won't show up if saved when using a "incognito window". Before doing this exercise, clear your browser cache and disable any settings which allow auto URL and/or saving any other browser settings.

  1. Select "New incognito window" from the three vertical dots in the upper right corner of the browser.
  2. A new "incognito window" will open.
  3. Browse sites as usual.
  4. While in the "incognito window", bookmark pages (manually), by dragging them from the URL bar to folder in your bookmark bar.

What I found is those sites bookmarked while in a "incognito window", will not show (auto-populate) up in the URL box when typing address.

1
  • 1
    However, if turn on sync between devices, these bookmarks do show up in search. At least I think that is what happened in my case - they are all there now. Feb 22, 2021 at 15:47
1

Although Google seems to make this impossible, I have found a solution around the problem that works for me. I have certain bookmarks that I do not want some people like my family to see if they start typing into the address bar. So I use Xmarks (bookmarks backup and access) and Torch (web browser). I keep one account for all bookmarks including private with Xmarks so that I can access my bookmarks with password anywhere from any browser and backed-up. I keep all private bookmarks out of Chrome but store them in the Torch browser for private browsing. Torch is exactly like Chrome and compatible with all extensions with the bonus of downloading videos. As long as the family doesn't use the Torch browser, they will never see my private bookmarks.

1

The easiest way I have found that does not involve installing extensions is using a URL shortener (bitly, tinyurl) to mask the URL and save the shortened URL as the bookmark.

Hope this helps!

1
  • Good idea. Or you could edit the titles of the bookmarks. Feb 22, 2021 at 15:49
0

You could use Atavi Bookmarks, or just manually save a bookmarks.bak from your AppData\Local\Google\Chrome\User Data\Default folder.

0

Fauxbar lite worked for me. It is a chrome extension. The reason I was looking for this, is so that "adult bookmarks" hidden in nested menu's don't show up in the address bar, when my 9 year old borrows my laptop.

-1

An even simpler solution I found if you have bookmarks that you do not want showing up when you type in the Chrome address bar/omnibox is to use the "Secure Bookmarks" extension. This allows you to transfer some or all of your bookmarks to the extension, which is passworded and easily accessible when you need them. This will stop them from showing up in the address bar.

I resent that this took me hours to discover because Google refused to give us the option.

1
  • 1
    this doesn't seem very good, the password that extension requires has to be quite long.. it doesn't let you use a simple password like 'a' (and that's even putting aside whether the extension allows a plain text backup of bookmarks it contains)
    – barlop
    Sep 15, 2018 at 6:57
-1

https://www.youtube.com/watch?v=-FOClvwyewc Helped me a lot and solved all the problems. The video talks about a google chrome extension.

4
  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Sep 1, 2021 at 21:26
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – Ramhound
    Sep 1, 2021 at 23:22
  • I was very tempted to flag this answer as spam, the name of the author of the video, was too close for my taste.
    – Ramhound
    Sep 1, 2021 at 23:22
  • Oh my bad. I'm new and wanted to share an answer to a question I figured out. Didn't the possibility consider the link expiring.
    – jk gan
    Sep 2, 2021 at 6:44
-3

You can also just go to setting, then go to the bottom of the page an hit "show advanced settings". An under "privacy" you can un-check the box " Use a prediction service to help complete searches an URLs typed in the address bar or the app launcher search bar". This will prevent your book marks from coming up but only in regular chrome not in "incognito" mode. Also you may have to be more detailed in your searches to get what you need when searching.

I hope that this helps.

1
  • wrong. this only turns off google search suggestion. bookmarks still show up.
    – guest
    Jun 22, 2016 at 9:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .