I am learning to create device drivers for windows. Upon trying to deploy my first driver I encounter this error when I try to start the service:

System error 1275 has occurred.

This driver has been blocked from loading

I am using Windows Driver Kit Version 7.1.0. Tried to build the .sys file for /386 and /ia64 architectures. Tried to sign both files with a self-signed certificate. Finally disabled the signature checking (F8 during boot-up and selected "Disable Driver Signature Enforcement") and tried with both signed and unsigned driver. Still getting the same error.

Any ideas what could be done? The driver is being loaded by the service control manager but the error appears when I actually try to run net start MyDriver.

Update: Signing is done using the command: Signtool sign /v /s PrivateCertStore /n MyCert /t http://timestamp.verisign.com/scripts/timestamp.dll driver.sys i.e. I use an embedded signature. Also the MyCert certificate is from the Trusted Root Certification Authorities certificate repository (available certificates can be seen by executing Ctrl+R, certmgr.msc)

  • Just making sure, whatever is deploying the driver is running as admin, right? – Jon Aug 18 '13 at 19:59
  • Yes. I invoke cmd.exe as admin (CTRL+R, type cmd.exe, Ctrl+Shift+Enter). In the opened command line I call an .exe file to load the driver as a service. The service is loaded by using OpenSCManager() and CreateService() functions. – Eugen Aug 18 '13 at 20:07

This error happens if you try to install a 32 bit driver on a 64 bit machine.


Guess problem occurred due to driver issues,it might be a solution ,

Run command prompt

Enter command "shutdown /r /o /f /t 00"

Click the "OK" button

System will restart to a "Choose an option" screen

Then select "Troubleshoot" from "Choose an option" screen

Then select "Advanced options" from "Troubleshoot" screen

then select "Windows Startup Settings" from "Advanced options" screen

Click "Restart" button

System will restart to "Advanced Boot Options" screen

Select "Disable Driver Signature Enforcement"

Restart & install drivers...

this might help you in installing drivers without any blocking,

  • I already enabled the "Disable Driver Signature Enforcement" (see the question). The problem persists. Btw. there is not "/o" argument for the shutdown command. What is it used for? – Eugen Aug 19 '13 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.