79

I want to change the default timeout in Chrome. In Firefox I can set the value of network.http.connection-timeout in about:config - but how can I do that in Chrome?

2
  • In case anyone comes here wondering how to simulate XHR connection errors while developing web apps, you can use device mode to do so. Apr 13, 2015 at 7:50
  • Note that newer versions of Firefox no longer use that configuration. It also uses the system-level configuration which can be changed as mentioned in NOSUKE's answer.
    – ADTC
    Oct 21, 2017 at 22:31

3 Answers 3

79

You can't. Google has been ignoring requests to implement this feature for over six years, so I wouldn't hold your breath.

5
  • 4
    WOW. That is why Chrome should not be the dominant Browser. Just because Google does not like something, they should not be able to prevent it.
    – Blackbam
    Mar 7, 2018 at 12:51
  • @Blackbam I can't and won't agree with you. If anything they are pushing vendors and everyone else to deliver better user experiences. There is no need to wait for a page to load above a certain threshold time. If the server can't handle the requests, it's better to kill active pending request, so the server doesn't die of overload.
    – Rumplin
    Jan 30, 2020 at 18:07
  • 3
    @Rumplin A user should have the power to change it. You can not deliver pages which load like super long. But still you should be able to configure a tool to certain needs.
    – Blackbam
    Jan 30, 2020 at 18:57
  • 1
    Ironically, this is the most annoying (for me) on drive.google.com
    – ViperGeek
    Feb 5, 2021 at 19:14
  • @Rumplin Looking at weight and performance of Google services, and how memory-hungry the Chrome itself, and how they ignore all the negative feedback people give, and how they discriminate other browsers based on their User-Agent (Opera and Vivaldi in particular), and all the lack of configurability, etc., etc., they clearly don't care about real user experience, but only what they think user experience is about! Speaking of timeouts, in my recent tests I haven't got any connection or response timeouts at all for 15+ minutes.
    – EvgenKo423
    Apr 24 at 15:15
16

It's hopeless. They just won't do anything about enabling users to change Chrome's timeout settings. But you could switch to any of four other Gecko-based browsers in common use that have no timeout problems. Or you could start using one of the Mozilla-based browsers.

2
  • 2
    I was tempted to mark this as "not an answer", but I realized that you are suggesting an alternative solution. I would suggest editing it and indicating that so others aren't tempted to downvote or flag it.
    – user201262
    Sep 12, 2013 at 19:05
  • 2
    Mozilla is Gecko based.... WebKit / Blink (Google's WebKit fork) is probably what you meant? Feb 2, 2017 at 19:11
5

I dealt with this issue by editing the registry. I think the registry affects not only IE but also Chrome in Windows 10. I tried extend time-out. then I can extend it and max time-out is about 7Hrs in my case.

Reference: Microsoft Support

Click Start or press Win-R to get Run box, type regedit, and then click OK.

Locate and then click the following key in the registry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

On the Edit menu, point to New, and then click DWORD Value.

Type KeepAliveTimeout, and then press Enter.

On the Edit menu, click Modify.

Type the appropriate time-out value (in milliseconds), and then click OK. For example, to set the time-out value to two minutes, type 120000.

Make another DWORD value ServerInfoTimeout and set it to the same value.

Restart machine.

1
  • 1
    As of today, this doesn't seem to work
    – shayaan
    Dec 14, 2017 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.