Before you close this as a duplicate, please read carefully.

In Windows XP, when there was a problem with Wifi, you could right-click on the icon, and the context menu allowed you to disable/enable the network adapter.

In Windows 8 (not sure about 7 since I haven't used a laptop) I need to search all over for network connections in the Control Panel (well, figure out network connections is what I want first since this doesn't happen that often). Then I need to select Wifi with the mouse, and hit Disable along the top, then make sure Wifi is still selected, then hit Enable along the top.

The Microsoft help says their troubleshooter will do this automatically - but, either it does not, or it's giving me the wrong troubleshooter, or something else is wrong, because running the troubleshooter did not solve the problem but painstakingly resetting the adapter did (as it always has).

Is there an easy way to do what I used to do (cycle the adapter quickly), or at least reset things from the Wifi Metro tab, rather than navigating all over for the correct Control Panel page?

Thank you.

  • I'm not 100% sure if I understand what you want, so I'll ask cautious: Would you please test this batch and report back if its what you are looking for? – nixda Aug 19 '13 at 20:10
  • Does the laptop have a key or switch to turn off wifi? I only have one laptop with wifi problems at the moment but that's all I do when I see the dreaded yellow triangle, turn off the wifi key, and turn it back on. – Tyson Nov 8 '14 at 23:51

Right click the wifi icon. Try troubleshooting.

If it doesn't work, open "network and sharing center".

Click on "change adapter settings" on the left side.

Right-click your wifi adapter, disable it. Right-click again, enable it.



In a cmd prompt with Administrator privileges, give this command:

powershell -Command "get-netadapter wi-fi | restart-netadapter"

You could also create a shortcut using the following target:

C:\Windows\System32\cmd.exe /c powershell -Command "get-netadapter wi-fi | restart-netadapter"

Make sure you click Advanced in the shortcut's settings and set it to run as Administrator.

If you want to eliminate the UAC Administrator prompt as well (as you would), you could try following these instructions to create an elevated Windows task and a shortcut to run it, using the schtasks command, but I personally haven't been able to get it UAC-prompt-free on Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.