I own an old 20 GB Creative Zen jukebox (all external screws are gone on it - LOL), and I would like to transfer files back to my PC to get them on my new iPod. The problem is, no matter what software I use (Winamp, Creative MediaSource or Windows Media Player), it just stops transferring files on my HDD with an error message that says there is no more space on the destination folder.

The problem is, there is still 320 GB free. I tried lot of things like installing a newer driver, latest Zen plug-in for Media Source, and latest Winamp version. Sometimes, it just works and then again, it stops working, and I get this non-sense error. Restarting my PC sometime solves the issue by giving me enough time to transfer 10 or 15 more files, and then I get the error again and again. Yesterday though, I managed to transfer up to 3 GB of MP3 files on my computer before getting the error.

It seems like I'm having a driver issue or a weird behavior from the player and/or the software I'm using. Three different software can't reproduce the exact same issue by themselves, so it must be something related to the driver. I can't find any post of any sort concerning such issue in old forum posts.

Any idea?


After searching for an answer without result, I noticed I got the error message every time the free space on my HDD was a multiple of 4GB. At exactly 320.0GB, I couldn't transfer files from my player anymore so I created a temp folder with placeholders using 5MB on disk and... I could resume transfer of files up to 4GB (leaving 316.0GB free space on my disk). I'm in disbelief, it appears the driver is probably fetching free space information in a variable too small to contain the number of bytes available on my HD, yet the MP3 player itself has a 20GB HD into it.

  • ??! weird ... very ... – Rook Feb 21 '10 at 23:25
  • @JP: Apparently it works for you now; otherwise I would have suggested upgrading the firmware (which should be able to find somewhere, I suspect, even if it is an old player). I fixed a similar issue (well, kind of: it was reversed) for a friend with a MuVo just by re-flashing the drive. I don't even know if it was a newer version of the firmware, just something that had gone bugger-up. – Daniel Andersson Apr 5 '12 at 17:36

Nomadsync worked for me when i had trouble getting stuff off my zen xtra - it uses libmtp instead of the built in windows mtp support, which is what i think the rest use


Can you directly open the player in windows explorer? I just played with my Sansa clip and found that I was able to open it as a normal folder whether it was in MTP or MSC mode. If you can, you should be able to see the music files and directly copy them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.