I have set-up Synergy with an OSX server and a Ubuntu host. It's working nicely, except that the mouse wheel doesn't work in Linux. I used to xev command to verify that no input at all is registered when operating the mouse wheel.

I have found various bug reports about this problem, dating back from 2009, but no solution.

I also found a few blog posts where source-code patches can be downloaded. But when I tried to build the code I got errors about a missing i386 directory. (I fear that trying to build the project myself will lead to many hours of frustration..)

Does anyone know where I can download a OSX build with the applied patches?


I found the answer here

Fix for every installation so far -- I see mostly people using linux as the client so in this scenario I'm using Windows 7 as the server and fedora 12 as the client.

On the client:

tail -f /var/log/messages

now scroll as slow as possible and take note of the errors streaming in.


Feb  1 18:32:45 localhost Synergy+ 1.3.4:
2010-02-01T18:32:45 WARNING:
Wheel scroll delta (28) smaller than threshold (120)#012#011CXWindowsScreen.cpp,858

This is pretty self-explanatory. Take note of the delta. For this setup, when I scroll slow, I get 28.

So now run this on the client:

killall synergyc; sleep 1; synergyc --yscroll <lowest delta> <ip of server>

Literal example:

killall synergyc; sleep 1; synergyc --yscroll 28

Make sure to go through any session files or setting you created to include your new yscroll function.

And don't use 0 or 1 (unless your delta is 1). 0 created some odd issues. You want to set yscroll to your lowest possible literal delta. 0 or 1 neither accurate nor efficient.

  • 1
    +1 Also, (on a Mac host at least), the Scroll Speed system preference allows some adjustment to the scroll delta. – Seth Sep 27 '15 at 16:52
  • How do i accomplish this on a windows client? putting those messages into cmd prompt gives me errors. Thank you! – Govind Rai Sep 9 '16 at 20:23

These steps should help. On your mac

  • Go to System Preferences > Mouse
  • Change scroll speed to lowest
  • Restart Synergy server on your mac (you may test even before restarting server. Worked for me without a restart)
  • Voilla!! Scroll should be working on both linux and mac.

Now you can go back and adjust the speed of the scroll using the same steps and test it.

  • 1
    I did find it was to do with scroll speed but the option isn't (or no longer is) found in System Preferences -> Mouse, it's in Accessibility -> Mouse and Trackpad. – Mike Mellor Aug 14 '18 at 11:27
  • 1
    3yrs later and this saved me!!! – John Siu Sep 5 '19 at 4:01

On Mac in terminal I had to go run: cd /Applications/Synergy.app/Contents/MacOS

Then run: killall synergyc && sleep 10 && ./synergyc --yscroll

Example: killall synergyc && sleep 10 && ./synergyc --yscroll 28

  • This looks a lot like the two-year-old answer.  What, exactly, are you saying (i.e., what, if anything, are you adding to the existing answer)?  Are you saying that sleep 1 isn't enough?  Are you saying that you need to be in the /Applications/Synergy.app/Contents/MacOS directory for this to work?  Or are you just saying that you don't have that directory in your PATH, and so just running synergyc from an arbitrary directory doesn't work?  … … … … … …  In any case, showing the ./synergyc --yscroll command without all the required parameters is confusing. – Scott Oct 16 '15 at 16:44
  • sleep 1 was not enough, also you need to be in the directory for it to work. – wd4ever Oct 21 '15 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.