Prompted by the answers to this question I decided to give the Windows built in time synchronisation another go.

However, no matter what time server I use I get this error:

"An error occurred while Windows was synchronizing with [name of time server]."

The help suggests the following as reasons for failure:

  • You are not connected to the Internet. Establish an Internet connection before you attempt to synchronize your clock.
  • Your personal or network firewall prevents clock synchronization. Most corporate and organizational firewalls will block time synchronization, as do some personal firewalls. Home users should read the firewall documentation for information about unblocking network time protocol (NTP). You should be able to synchronize your clock if you switch to Windows Firewall.
  • The Internet time server is too busy or is temporarily unavailable. If this is the case, try synchronizing your clock later, or update it manually by double-clicking the clock on the taskbar. You can also try using a different time server.
  • The time shown on your computer is too different from the current time on the Internet time server. Internet time servers might not synchronize your clock if your computer's time is off by more than 15 hours. To synchronize the time properly, ensure that the date and time settings are set close to your current time in the Date and Time Properties in Control Panel.

Now the first reason is clearly wrong - I am connected to the internet.

I can see the 2nd being the most likely cause. I have Sygate Personal Firewall running, but it normally asks if something it trying to connect for the first time. Does anyone know I can unblock the NTP protocol - or at least check if it is blocked?.

I don't think it's #3 or #4 as I've tried a number of different servers including the one currently used by Atomic Clock Sync. Though if someone knows the address of a UK time server I can double check this.

up vote 2 down vote accepted

You can add a new rule to SPF following the steps delineated here. The application is w32Time located under System32 is memory serves right.

However if SPF doesn't complain, the problem is certainly elsewhere. I see to remember having had problems with time sync before. I really can't remember what the reason was in end. But two things seem to nag me:

  • The service was stopped or in Manual or something, and needed to be in Automatic(?).
  • My router was blocking it

Errors coming from the time servers alone seem unlikely. As you say you have tried others. But in any case KB262680 contains huge lists of time servers you can use.

Meanhile KB314054 reveals manual configuration instructions of the service in the registry along with a detailed explanation of all keys further down the page. Could be a case of a bad registry configuration.

All the best.

  • I had to edit the registry in the end to get it to work. – ChrisF Oct 31 '09 at 15:22

Sometimes the problem is simply the windows time service. It seems to get confused every now and then and need to be restarted. This is especially true of older Windows releases and remains true for Windows 7.

Go to the "Administrative Tools" open the "Services" console (as administrator) and find the Windows Time service. Right click on it and choose Restart.

  • Yup, that did the trick. Simply restarting the old, senile Windows Time service got it to sync on the first try. – Synetech Nov 28 '16 at 18:26

Also, if your computer is quite old and you did a restore/recover, be sure that the time, day, month and YEAR are as close as possible before synch.

  • AND, try a different Server such as a .gov or .mil (tick.usno.navy.mil works as of 2016-02-15)
  • As Well As

In the "Internet Time" tab, click "Change settings".

  • Search for an NTP server that's close to your location, here's a great search engine that gives you a good NTP server closest to your location (watch out the bold link, select & copy it to clipboard), but there are also continent, country and regional links, so get as close as you can.

  • In the "Server" text box, enter the link of the NTP server you selected

  • Click "Update now"
  • That should work

enter image description here

Try to run the following commands in CMD (as administrator):

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
w32tm /config /manualpeerlist:pool.ntp.org /syncfromflags:manual /update

It should update the clock and print out this:

C:\Documents and Settings\user>net stop w32time

The Windows Time service is stopping. The Windows Time service was stopped successfully.

C:\Documents and Settings\user>w32tm /unregister

W32Time successfully registered.

C:\Documents and Settings\user>w32tm /register

W32Time successfully registered.

C:\Documents and Settings\user>net start w32time

The Windows Time service is starting. The Windows Time service was started successfully.

C:\Documents and Settings\user>w32tm /config /manualpeerlist:pool.ntp.org /update

The command completed successfully.

Resetting time services worked for me (Windows 8.1):

Restart the Windows Time service.

  1. Press “Windows Logo” + “R” and type “services.msc” in the run command window.
  2. In the “Service” window scroll down to “Windows Time”.
  3. Double click on it and click on “Start”, if it is stopped.
  4. If it is already running, then stop it and then restart it again.
  5. Change the “Startup Type” to “Automatic”.
  6. Click “Apply” and “OK”.
  7. Restart the computer and check if you are able to synchronize the time with the “time.windows.com”.

I solved this problem by rebooting my router. My router was apparently in a weird state as I was having problems with other URLs as well.

  • 1
    This was posted as an answer, but it does not attempt to answer the question. It should possibly be an edit, a comment, another question, or deleted altogether. – Ramhound Sep 18 '17 at 22:46
  • @ramhound you're absolutely right, but I would challenge the fact that the accepted answer, answered the question. This problem seems to occur due to different reasons, one of it being what I described. – Arthur Sep 19 '17 at 11:09
  • It sounds like your problem had very little similarities to the author's question in that case. Does not change the fact this answer, does not attempt to answer the author's question – Ramhound Sep 19 '17 at 12:16

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.