Prompted by the answers to this question I decided to give the Windows built in time synchronisation another go.

However, no matter what time server I use I get this error:

"An error occurred while Windows was synchronizing with [name of time server]."

The help suggests the following as reasons for failure:

  • You are not connected to the Internet. Establish an Internet connection before you attempt to synchronize your clock.
  • Your personal or network firewall prevents clock synchronization. Most corporate and organizational firewalls will block time synchronization, as do some personal firewalls. Home users should read the firewall documentation for information about unblocking network time protocol (NTP). You should be able to synchronize your clock if you switch to Windows Firewall.
  • The Internet time server is too busy or is temporarily unavailable. If this is the case, try synchronizing your clock later, or update it manually by double-clicking the clock on the taskbar. You can also try using a different time server.
  • The time shown on your computer is too different from the current time on the Internet time server. Internet time servers might not synchronize your clock if your computer's time is off by more than 15 hours. To synchronize the time properly, ensure that the date and time settings are set close to your current time in the Date and Time Properties in Control Panel.

Now the first reason is clearly wrong - I am connected to the internet.

I can see the 2nd being the most likely cause. I have Sygate Personal Firewall running, but it normally asks if something it trying to connect for the first time. Does anyone know I can unblock the NTP protocol - or at least check if it is blocked?.

I don't think it's #3 or #4 as I've tried a number of different servers including the one currently used by Atomic Clock Sync. Though if someone knows the address of a UK time server I can double check this.

9 Answers 9


You can add a new rule to SPF following the steps delineated here. The application is w32Time located under System32 is memory serves right.

However if SPF doesn't complain, the problem is certainly elsewhere. I see to remember having had problems with time sync before. I really can't remember what the reason was in end. But two things seem to nag me:

  • The service was stopped or in Manual or something, and needed to be in Automatic(?).
  • My router was blocking it

Errors coming from the time servers alone seem unlikely. As you say you have tried others. But in any case KB262680 contains huge lists of time servers you can use.

Meanhile KB314054 reveals manual configuration instructions of the service in the registry along with a detailed explanation of all keys further down the page. Could be a case of a bad registry configuration.

All the best.

  • I had to edit the registry in the end to get it to work.
    – ChrisF
    Oct 31, 2009 at 15:22

Try to run the following commands in CMD (as administrator):

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
w32tm /config /manualpeerlist:pool.ntp.org /syncfromflags:manual /update

It should update the clock and print out this:

C:\Documents and Settings\user>net stop w32time

The Windows Time service is stopping. The Windows Time service was stopped successfully.

C:\Documents and Settings\user>w32tm /unregister

W32Time successfully registered.

C:\Documents and Settings\user>w32tm /register

W32Time successfully registered.

C:\Documents and Settings\user>net start w32time

The Windows Time service is starting. The Windows Time service was started successfully.

C:\Documents and Settings\user>w32tm /config /manualpeerlist:pool.ntp.org /update

The command completed successfully.

  • Ran this, Synced again, and it works! Jun 30, 2021 at 11:11

Sometimes the problem is simply the windows time service. It seems to get confused every now and then and need to be restarted. This is especially true of older Windows releases and remains true for Windows 7.

Go to the "Administrative Tools" open the "Services" console (as administrator) and find the Windows Time service. Right click on it and choose Restart.

  • Yup, that did the trick. Simply restarting the old, senile Windows Time service got it to sync on the first try.
    – Synetech
    Nov 28, 2016 at 18:26

Resetting time services worked for me (Windows 8.1):

Restart the Windows Time service.

  1. Press “Windows Logo” + “R” and type “services.msc” in the run command window.
  2. In the “Service” window scroll down to “Windows Time”.
  3. Double click on it and click on “Start”, if it is stopped.
  4. If it is already running, then stop it and then restart it again.
  5. Change the “Startup Type” to “Automatic”.
  6. Click “Apply” and “OK”.
  7. Restart the computer and check if you are able to synchronize the time with the “time.windows.com”.

Also, if your computer is quite old and you did a restore/recover, be sure that the time, day, month and YEAR are as close as possible before synch.

  • AND, try a different Server such as a .gov or .mil (tick.usno.navy.mil works as of 2016-02-15)
  • As Well As
  • That is true. I have been completely unsuccessful, 19 consecutive attempts when date was at 2099; then after manually changing it to the current year, it instantly processed "update now" correctly and with no error msg. How disappointing that this suggestion (to get the time setting "close" or sync will fail) is hardly or never made except in an obscure entry like this one I'm commenting on (which had zero upvotes), when several times in my life it was the pure answer. Jun 28, 2020 at 20:01

Was having this problem with a windows 11 ARM virtual machine as VMware tools does not keep the time up to date. Run this batch script on login to fix the time from the internet.

REM Use PowerShell to fetch the time and date from an internet time server
for /F "usebackq tokens=*" %%G in (`powershell -command "(Invoke-RestMethod -Uri 'http://worldtimeapi.org/api/timezone/America/Chicago').datetime"`) do (
    set "utc_datetime=%%G"

REM Separate the date and time components
for /F "tokens=1,2 delims=T" %%a in ("%utc_datetime%") do (
    set "utc_date=%%a"
    set "utc_time=%%b"

for %%a in ("%utc_time%") do set "utc_time=%%~na"

set "originalDate=%utc_date%"

REM Extract individual components of the date
set "year=!originalDate:~0,4!"
set "month=!originalDate:~5,2!"
set "day=!originalDate:~8,2!"

REM Create the new date in mm-dd-yy format
set "utc_date=!month!-!day!-!year:~2,2!"

REM Display the obtained time and date
echo UTC Date: %utc_date%
echo UTC Time: %utc_time%

date %utc_date%
time %utc_time%


In the "Internet Time" tab, click "Change settings".

  • Search for an NTP server that's close to your location, here's a great search engine that gives you a good NTP server closest to your location (watch out the bold link, select & copy it to clipboard), but there are also continent, country and regional links, so get as close as you can.

  • In the "Server" text box, enter the link of the NTP server you selected

  • Click "Update now"
  • That should work

enter image description here


I had the same problem, tried every step listed here and on Microsoft's support, i.e. from disabling firewall to enabling "Windows Time" service, and everything else but nothing worked.

Then I connected my laptop to other network, and it worked.

In my case, the problem is with the Wi-Fi/router. Though, I didn't face any issue with time synchronization with Ubuntu.

  • Avoid posting answers to old questions that already have answers unless you have something substantial and new to add.
    – Toto
    Sep 20, 2022 at 15:01

I solved this problem by rebooting my router. My router was apparently in a weird state as I was having problems with other URLs as well.

  • 1
    This was posted as an answer, but it does not attempt to answer the question. It should possibly be an edit, a comment, another question, or deleted altogether.
    – Ramhound
    Sep 18, 2017 at 22:46
  • @ramhound you're absolutely right, but I would challenge the fact that the accepted answer, answered the question. This problem seems to occur due to different reasons, one of it being what I described.
    – Arthur
    Sep 19, 2017 at 11:09
  • It sounds like your problem had very little similarities to the author's question in that case. Does not change the fact this answer, does not attempt to answer the author's question
    – Ramhound
    Sep 19, 2017 at 12:16
  • Thanks for the info @Arthur ! I appreciate you adding it. I think I might be having a similar problem.
    – Ari Seyhun
    Apr 7, 2020 at 11:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .