1

I used to use Intel My Wifi Technology to turn my Window 7 laptop into WiFi hotspot so that my Android phone can connect to my laptop and use the Internet connection to download apps. Somehow it is not working any more. I can see on laptop the connection gets on and off constantly, and my Android phone does not locate the WiFi hotspot any more.

I tried several ways:

  1. I tried to use my Android phone in public library where it is working via WiFi provided there. so WiFi on my Android phone works.
  2. I tried to set up my own WiFi hotspot according to instruction found after online search. The problem stays same without using Intel My Wifi technology. It seems like my laptop does not emit WiFi signal correctly. But my laptop can use public WiFi without problem.

I need this working because reverse tethering via USB needs to root my Android device. That I don't want.

  • Have you tried connecting another device to your laptop this way? I know you can get onto another access point with your android but sometimes this sort of thing can happen. Maybe someone else has a phone or a laptop that you could try with? – Richard Powell Aug 23 '13 at 12:08
  • Al Everett, thank you for your proofreading. I am surprised of the detail level you focused on. Richard, I'll try what you said. – Michael Aug 23 '13 at 13:06
2

Did you tried to set: Hosted Network with ICS it is pretty simple :)

edit: to spare your time in cmd write:

netsh wlan set hostednetwork ssid=name key=password mode=allow
netsh wlan start hostednetwork

netsh wlan show hostednetwork - this will show hostednetwork status

Remember that your Wifi card is required to be turned on. If you set this corectly you can find your virtual wifi in your network center > network adapters (or something like that). Now you can easy edit it's settings like ICS and share your Internet !

  • yes, I tried what you said. It is the same problem as Intel MyWiFi technology. Intel MyWiFi said something like "The interface is already used". How do I turn off Intel MyWiFi? – Michael Aug 26 '13 at 13:49
  • I got WiFI connected but ICS is not set correctly. How do I post screenshot here? – Michael Aug 26 '13 at 14:17
  • You can host images in outer services or FTP until you get a higher reputation. To set ICS right. After creating Host AP chose your WiFi connection and share it. In it's settings check all squares and set home network as: Virtual WiFi. Clik Settings... button and check all the squares there. Check this link: link to turn your Intel MyWiFi off – NightKn8 Aug 28 '13 at 8:35
0

If you are connected to the hotspot and you have enabled the sharing in the Source connection (the one which is source of internet), by selecting the name mentioned below the hotspot you made( It will be like wireless connection 1 or wireless connection 2 and so on). Than in that case click the ICS (Internet connection sharing) setting and check all check Boxes. Follow step by step as below

like if you are sharing LAN than go to LAN properties -> sharing -> enable sharing check Box -> select the wireless connection corresponding to your hotspot. till now done and no internet than below the enable sharing there is ICS Internet connection sharing settings click ICS link and than check all check Boxes. That's it. please excuse typos if there are any.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.