1

So a few months ago, I bought a new MS mouse, and was surprised that they'd discontinued Intellipoint in favor of this Microsoft Mouse and Keyboard Center. It seems to have the same functionality underneath all the bloat, but there's a very serious drawback - when I set up application-specific functions for the extra buttons on the mouse, they work, but sometimes with a very long delay, like up to a minute or more.

For example, I often set up the left side button as an "Undo" in various programs for convenience. But sometimes, when I try to use that Undo button, nothing happens, so I'm forced to use the standard Ctrl-Z or whatever. But then, a minute or so later, it suddenly remembers that I hit that button a while back, and calls the Undo unexpectedly on something entirely different. It's infuriating. No modern computer function should be this slow. It's not the software or the computer itself, because doing an Undo via Ctrl-Z or the menu still works instantly. It's very definitely a side-effect of delayed response to the mouse button. Usually after it delays the first time, it'll work quickly after that, but if you haven't used a given shortcut in several minutes, it "forgets" again and you get another inexplicably long delay.

Intellipoint never had this problem, but it's not supported any more, and not compatible with the newer mice. Has anyone else noticed slow-downs with MS M&K C and app-specific shortcuts? Any ideas how to get around this? I use these shortcuts extensively in my workflow and it's just entirely unacceptable to have such a long delay in what should be a pretty basic feature.

1

I haven't experienced the "forgetting" delay, but I have the same slowdowns in my keyboard. If I run the Microsoft Mouse and Keyboard Center configuration program, I find that keyboard shortcuts start working, without the delay.

That leads to a secondary problem - MMKC takes a long time to start up! But it does seem to work after that.

Another option: I haven't yet been driven to do this, but you could try getting old Intellipoint, and/or old Intellitype. Or an Intellipoint replacement. For 64 bit PCs, you can download Intellipoint and Intellitype from Microsoft, as the 32-bit versions don't work.

| improve this answer | |
  • I've tried that - doesn't seem to help. And yes, it does take a long time to start up. One thing that does work is rebooting the computer, but that's just ridiculous. I really shouldn't have to do that just to get my mouse buttons working reliably again... – Darrel Hoffman Oct 5 '13 at 13:55
  • Old versions, maybe? Updated. – Chris Oct 5 '13 at 14:29
  • 1
    I was able to get the old Intellipoint to install with that link, thanks. MMKC did not go quietly, however - first off, you can't install IP if MMKC is already installed, and uninstalling MMKC causes it to immediately start reinstalling automatically - without even asking permission. (I had to end-task the installer!) Seems to work now with IP, even though when I first bought the mouse the version of IP that I had installed at the time claimed not to support it. I'll upvote this, but won't call it solved until I've run with it for a few days in case the problem comes back somehow... – Darrel Hoffman Oct 5 '13 at 19:54
  • So after testing this for a few weeks - it's definitely improved - I think mainly due to the decreased bloat of IP vs. MMKC. And I like not having to deal with MMKC's ridiculous load time. However, the problem is not entirely gone. If the system is at all busy (> ~50% CPU usage), I still get the mouse shortcuts being delayed by up to 30 seconds or sometimes refusing to work altogether. Not sure what else it could be - maybe bad mouse drivers? USB drivers? Not sure what else to check... – Darrel Hoffman Oct 20 '13 at 1:40
  • Wow, that's serious. I added another link to an Intellipoint replacement question. As for me I'm going to stick with Logitech mice then. :-/ – Chris Oct 21 '13 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.