1

I've got a simple chrome/userContent.css in my profile:

% cat ~/Library/Application\ Support/Firefox/Profiles/7h7pwntq.default/chrome/userContent.css
@-moz-document domain(reddit.com) { 
  textarea {
    font-family: Monaco, monospace;
  }
}
%

But it doesn't seem to be working. I'm sure this is the right profile directory (it's the only one), and I've tried reloading pages and restarting Firefox to no effect.

What am I doing wrong?

0

1 Answer 1

5

Change:

@-moz-document domain(reddit.com) { 
  textarea {
    font-family: Monaco, monospace;
  }
}

to

@-moz-document domain(reddit.com) { 
  textarea {
    font-family: Monaco, monospace !important;
  }
}

So you need to add !important to over-ride the web page defaults and to use your own settings.

3
  • 1
    Worked! Edited, restarted the browser, good to go.
    – rampion
    Aug 27, 2013 at 4:31
  • Can this be applied to properties that are commented out? For example, I want to disable the "position: fixed;" rule of the top bar of this site so it doesn't follow me everywhere I scroll. So I commented it out in the ".top-bar._fixed" selector in my userContent.css file. But this was not able to override the rule in primary.css. Is there a special syntax for forcing this rule to override the default rule? Apr 16, 2020 at 22:12
  • @NicholasCousar you are asking one or two different questions here: 1. "How can I disable a CSS rule on a website using userContent.css?" and/or 2. "How do I change a position: fixed CSS rule to the default using userContent.css?" Please ask a new question on this site. Jan 27, 2022 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.