1

I tried to watch a DVD on my computer. I put it in and VLC started, but later on, it crashed when I tried to rewind as it often does.

Naturally, I opened My Computer to play the DVD with VLC. Unfortunately, when I sleected the DVD drive and pressed Enter, instead of running VLC as I expected, it ran some kind of program that was on the disc.

I have absolutely no interest in letting Sony run a program on my system. Granted it is (supposedly) only a Shockwave projector program, but I don’t exactly trust them. Besides, I don’t even like or care for deleted scenes, let alone whatever useless “bonus materials” the program provides (usually just wallpapers, ringtones, and other equally meaningless junk).

Anyway, I was surprised by the program because I had already specifically set the default programs and actions for various media. I right-clicked the DVD drive and found that the default action is Run Enhanced Content.

First, I checked the AutoPlay settings and the action default action for when a disc is inserted is indeed set to VLC. The problem is that this has no effect on the context-menu you see when right-clicking the DVD drive in My Computer (or worse, pressing Enter).

Of course my next reaction was to check the registry to delete the Run Enhanced Content entry. Unfortunately there isn’t one. I checked HKCR\DVD\shell but the default action is PlayWithVLC and there is nothing that could correspond to running the program of “enhanced” discs. (In fact, I put a different DVD in that definitely has no such content and yet Explorer is still showing me the menu entry, and not surprisingly, using it gives an error about being unable to run the non-existent program.)

Does anyone know how to disable or remove the menu-entry?

Screenshot of Enhanced-Content menu-item of DVD

  • Just as a starter: that menu item is defined in some .INF file on the cd. (Sorry, not on Windows and don't recall the name. Maybe autorun.inf?) Once you know its name, maybe you can change the title, as "Run Enhanced Content" is indeed very specific. – Arjan Aug 27 '13 at 19:52
  • Ah, indeed autorun.inf. – Arjan Aug 27 '13 at 19:53
  • Oops, I missed your "yet Explorer is still showing me the menu entry, and not surprisingly, using it gives an error about being unable to run the non-existent program". Confused now...! If time permits: what if you restart Windows Explorer and try again for that clean DVD...? – Arjan Aug 27 '13 at 19:56
  • 1
    It’s not autorun.inf, there is nothing special in it that would trigger that. In the case of this movie DVD, its contents are simply [autorun] ↵ open = PC_Clickme.exe which makes it is no different than any other autorun.inf on an application or game CD or DVD. It could be a combination of detecting the presence of autorun.inf with an open command, as well as the presence of a VIDEO_TS folder, but unfortunately that doesn’t really get me any closer to figuring out how to prevent Windows from offering the option (or even stopping it from being the default). – Synetech Aug 27 '13 at 22:55
  • It gets weirder... "I was only able to find "Run enhanced content" under the "Explorer" section - and that only while the "enhanced content CD" was in the tray." Also, "Enhanced CD" is a format, which I forgot about. Curious if anyone knows more! – Arjan Aug 27 '13 at 23:28
0

Technical / Method

Well it turns out that Microsoft, in its infinite “wisdom” made this dynamic, which means that it is difficult to fix (at least cleanly).

Whenever you attach a media device (CD, DVD, flash-drive, memory-card, iPod, etc.), Explorer reads the device and determines a set of actions that can be performed with it, including Autorun actions extracted from the disc. It then creates a registry entry under HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2. There will be some GUIDs which correspond to different media devices, and the one corresponding to the disc-drive in question will get an AutoRun key which contains the string Run enhanced content. Modifying this string reflects in Explorer when you right-click the drive. Deleting this key makes the context-menu entry go away.

Problem

The problem is that when you eject the disc, Explorer automatically deletes the sub-key itself and recreates it whenever you insert a disc that contains “enhanced content”.

Test

Examining the surrounding keys in the branch, I found a few keys that had a subkey called _Autorun. On a hunch, I created one for my DVD drive, suspecting that it might be a flag of some sort that tells Explorer that AutoRun is disabled for this device. Sadly, it didn’t work; Explorer deleted it when I inserted a disc.

Potential Solution

Another possible solution is to simply disable AutoRun (but not Autoplay) altogether. You should be able to do this by using a program (TweakUI did this in XP) or by setting the following registry key:

[HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:000000ff

If this works for you, great, but if not (it didn’t work with my test), then you’ll have to try something more extreme.

Hack-y Solution

One option is to delete the AutoRun subkey and then remove permissions from the parent Shell key so that Explorer cannot recreate it. I tried this and sure enough, the menu entry was no longer provided when I ejected and reinserted the disc.

The problem with this is that the drive in question will not respond correctly to any sort of AutoRun or Autoplay and restoring that functionality would require adding permissions to it and deleting the Shell key.

It’s not ideal, but at least it works to enforce Explorer to use the action specified in the Control Panel for all drives instead of exposing users to per-disc potential exploits.

Summary

This is the solution I’m using for now, but if anyone can find a setting that works more cleanly, then even better.

Screenshot of guilty registry entry

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.