26

I have downloaded some fonts and installed them by double-clicking to open them, then clicking "Install font". Word and other Windows programs can see them, but GIMP does not list them in the text tool. Why is this?

These are TrueType fonts (packaged in .ttf files). I'm using Gimp 2.8.2

6 Answers 6

31

I am also using Win10, and here's a better solution.

In Gimp 2.8.22:

  1. Go to EDIT --> PREFERENCES --> FOLDERS (expand this) --> FONTS
  2. Click on FONTS
  3. On the right side of the window it will display FONT FOLDERS
  4. Add your C:\Windows\FONTS folder using the ADD button (icon on the left that looks like a page), and select the folder (open folder icon on the right)
  5. Press OK, etc. until all the windows are closed
  6. Exit out of GIMP and restart the application (this is what I did)

Now, you need to add all these FONTS to your toolbox.

  1. Click on the Tool options triangle at the upper right
  2. ADD TAB (expand)
  3. Select FONTS

Check out an image of these menus expanded HERE.

Now all your system fonts should be visible and available for use.

7
  • 22
    Windows lets you install fonts on a per-user basis. This is the default if you click on "Install" in the font viewer, and fonts installed this way aren't stored in the main Windows font folder. To have Gimp use these fonts, also add the "C:\Users\{username}\AppData\Local\Microsoft\Windows\Fonts\" folder in step 4. To install a font for all users, right-click the font file and select "Install for all users".
    – GatesDA
    Jan 22, 2019 at 19:43
  • 1
    One of two additional things were required for me after clearing cache folder: delete one folder listed in Gimp Font Folder page that didn't exist (marked red circle) or copy the fonts from Windows font folder to /Users/[username]/.gimp-2.8/fonts/ folder. I did both then it worked finally. Mar 26, 2019 at 19:00
  • 4
    @GatesDA This was the only solution that actually worked. It deserves its own answer. Shame the question was locked. Mar 27, 2019 at 8:28
  • 1
    For me gimp errored when loading some of the windows fonts, unfortunately the font I needed was after the error, so I moved my fonts from the windows folder to the gimp roaming folder and it worked Sep 14, 2019 at 11:45
  • 1
    @GatesDA of course! I feel like such a dummy right now. Though would it be too much to expect GIMP to look there by default? Jan 16, 2020 at 18:05
18

After checking a few similar posts elsewhere, it is usually fixed by clearing the font cache of GIMP. Although for some people even that does not work, and the case remains unsolved.

To clear the cache, browse to:
- XP and older:
Documents and Settings\[username]\Local Settings\Temp\fontconfig\cache
- Vista and newer:
Users\[username]\AppData\Local\fontconfig\cache

And delete the files there.

http://www.gimptalk.com/index.php?/topic/29683-font-loaded-not-showing-in-gimp-windows/
http://www.gimpchat.com/viewtopic.php?f=8&t=6615
http://gimper.net/viewtopic.php?t=644

10
  • I can't go to that folder, it says access denied. Google reveals that "C:\Users[username]\AppData\Local\Temp" should be the same, but I don't see a fontconfig folder there. Aug 28, 2013 at 12:07
  • You probably need to login as admin Aug 28, 2013 at 12:08
  • 2
    I found a "C:\Users[username]\AppData\Local\fontconfig\cache"? Is that the same? Aug 28, 2013 at 12:11
  • Apparently it is, since deleting the files there worked. So yay. Aug 28, 2013 at 12:14
  • 3
    On Windows 10 Enterprise 1709 64-bit, the cache was in %UserProfile%\.cache\fontconfig. Deleted it, restarted gimp and it reappeared as soon as gimp loaded. Had a .cache-7 extension.
    – EchoLynx
    Jul 22, 2019 at 21:20
10

On Windows 10 I had to copy TTF file in C:\Program Files\GIMP 2\share\gimp\2.0\fonts

1
  • Thanks - that was what I needed. I was going nuts as to why it wouldn't see thew new font! On the old version it worked by just adding to the overall windows fonts. Apr 29, 2019 at 6:44
3

I'm using GIMP 2.8 on Windows 10, and I tried the currently accepted answer from Juha. While GIMP did rebuild its font cache when I reloaded the program, the fonts I wanted were still not available.

In the end, I had to copy the .ttf files to C:\Users\[username]\.gimp-2.8\fonts

1

In Windows, if you install a font by just double-clicking it and then choosing install...

enter image description here

... it will install it for the current user only.

GIMP however only sees fonts that are installed "For all users".

To install a font for all users, right-click the font, then select "Install for all users":

enter image description here

-2

You need to add all font locations. For instance, if you downloaded a font, and it's in the download section, simply installing it through windows will not be sufficient. You also need to add the folder the .tff file is located in. Hence why some people are just moving fonts to gimp\2.0\fonts instead.

Not the answer you're looking for? Browse other questions tagged or ask your own question.