9

I had the below symptoms:

I remote to my computer, and after I login, the welcome screen comes out and hangs, I minimized the window and maximize again, then the remote desktop window became black and hangs, forcing me to reboot the computer before I can remote that computer again.

below is what I've tried (but doesn't work):

  • I login into another account (in the same computer) and killed all unnecessary processes In the remote desktop options,
  • I disabled audio playback in the "local resources" tab
  • Disabled persistent bitmap caching in the "experience" tab
  • Uninstall unnecessary processes

How can I solve this weird problem?

10
  • 1
    have you tried connecting, getting the hang, closing the RDP window entirely, and then reconnecting? I find that I have to do that occasionally. – Frank Thomas Aug 28 '13 at 14:18
  • This sounds like a software conflict on the remote computer. – Ramhound Aug 28 '13 at 14:25
  • what do you mean by closing RDP window entirely? – User2012384 Aug 28 '13 at 14:25
  • @Ramhound I've killed all process, and I'm quite sure that no other processes should be running, except some programms (i.e. excel, word, Visual studio, outlook, chrome) – User2012384 Aug 28 '13 at 14:27
  • @user2191496 - What security software do you have on the remote computer ( host )? What about the client? What software is on that? – Ramhound Aug 28 '13 at 14:35
10

This often happens to me when I connect to Windows 7 x64 machine. Solution that I use is pressing Ctrl-Alt-End in the RDP window. This brings up the "lock your computer" screen. Lock-Unlock and you are in!

1
  • 1
    All my internet points to you! – Nick Spreitzer Mar 6 '17 at 23:48
4

I had this problem for years. After a lot of research and experimentation, I created the following script and it works for me and some of my colleagues...

  1. Put the following in a text file and name it as .bat (like Release_RD.bat)

    tasklist -s your_remote_machine_name -fi "imagename eq mpnotify.exe"
    
    set /p pid=Enter PID found above:
    
    taskkill -s your_remote_machine_name  -pid %pid%
    
    pause
    
  2. If you aren't currently looking at the spinning Welcome screen, attempt to log in again so that your remote desktop client is actively on the Welcome screen

  3. Double-click the .bat script and follow the directions in it. You might have to run the script twice if there are multiple mpnotify.exe processes.

2

I've had this kind of problems in the past when I used client computers with buggy out of date nvidia graphic drivers.

This may be unrelated to your problem, but you might want to check that your drivers are up to date.

1
  • Just now updated the display driver on the remote computer....but the result is same....:( – User2012384 Oct 13 '13 at 2:44
2

In case this problem still happens, although Win 7 is leaving us soon....

I had this issue and found this way to solve it. On the remote Win 7 machine...

  1. Open Network and Sharing Center

  2. Click on Manage wireless networks

  3. Doubleclick the active network and check if Network availability is set to Me only. If that is the case, close window, select the network and choose Remove.

  4. Connect to the network again. This will set the Network availability to All users (if not, you may have to add the network manually in Manage wireless networks, or connect while loged in as admin (this last is just a qualified guess).

FYI: I found this solution at: https://social.technet.microsoft.com/Forums/windows/en-US/86c07850-f120-4b92-9575-dfc7cf57f788/wireless-before-login?forum=w7itpronetworking

Hope this helps. Cheers!

1
  • Thank you for your suggestion, I switched my company and I'm now using chrome remote desktop :P – User2012384 Oct 20 '19 at 1:08
1

Are you using Windows RDP? I've had some very weird problems in the past with Windows RDP - but on my linux box I find Remmina is much better. Maybe you should download it (it's open source > > for Windows and Linux) and give it a try to isolate the problem better. It could be a latency problem as well, what connection are you currently working with?

3
  • sorry, but I don't know what do you mean by "what connection am I currently working with", but I'll try Remmina if I can remote to the other computer, thanks for your suggestion – User2012384 Aug 28 '13 at 15:28
  • Hi - Sorry for the lack of proficiency here. I meant your connection speed. Also try to traceroute maybe to the server you RDP to. – Rudolph Aug 28 '13 at 15:29
  • 1
    current connection speed is 100.0MPS – User2012384 Aug 28 '13 at 15:32
1

Try this - RDP into the machine. Click Start => Computer => System Properties => Remote Settings => Advanced => Settings => Turn off any/all custom options => Apply => Ok. This appears to have fixed it for me.

1

I know this is very old. Just adding my 2 cents as I'm getting this problem few times in a day.

In RDP client I go to Experience and in Performance list change to whatever other option, log in, close and login again with your normal Performance options.

This can be switching between LAN 10Mbit and Detect connection automatically.

Fiddling with custom options and saving doesn't help in some cases. Toggling between Performance options (without save) seem to work all the time.

1

I use RDP to login to my work computer from my home tablet and have intermittently experienced the problem you describe, including requiring a reboot of the work computer before being able to login remotely again. In my environment, the intermittent nature of this problem was directly related to whether or not bluetooth was active on my tablet when initiating RDP. If bluetooth is active, RDP will hang 100% of the time. Since I use a bluetooth keyboard with my tablet, I must complete RDP login prior to activating bluetooth on tablet to avoid a hang.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.