0

Here is what I have: Dell Vostro 1500 laptop, Vista, Broadcom 440x 10/100 Toshiba Laptop, Vista Just bought a gigabit expresscard ethernet laptop adapter D-link DSL-6740U v.H1 ADSL modem/router 3 ft. Cat 5e ethernet cable Confirmed 100Mbps internet service from Bezeq Int'l and Bezeq infratructure (Israel)

Keep getting speed test results of no more than 40Mbps wired, on both laptops with native ethernet cards and also tried with gigabit expresscard on both computers Wifi on both laptops get no better speed A technician came and brought his laptop and it clocked at 95Mbps, I believe he had a Windows 7 computer Another technician at the ISP tech support also has same service and router and has no problems clocking around 95Mbps, though he is running Windows 7

Things I've tried:

updating firmware on modem/router = FAIL
disabling auto-tuning on vista via command prompt = FAIL
switching browsers from Chrome to IE = FAIL
buying new gigabit card = FAIL
turning off all firewalls and anti-viruses = only slight improvement at ~45Mbps
resetting modem/router = FAIL
going to network adapter settings in device manager and setting speed/duplex to 100Mbps full and 1000Mbps full on all laptops with and without the gigabit card = FAIL
no update available for the ethernet card on the Dell = FAIL

Is Vista the problem? If so, how can I fix it. What else can I try?

  • According to the spec sheet (dlink.ru/mn/products/3/1349_b.html) on that router, the max downstream rate is only 80Mbps... I am not sure how the tech could have gotten 95 or you could subscribe to 100mbps. The upstream is only listed as 40. – Mitch Aug 28 '13 at 21:16
0

First the question is what does this speed test, and on which protocol. The computer has also an impact on the performance. I think you Laptops are relative new so you can skip this.

I would look on to figures check the window size of you network configuration this has an major impact on TCP connections, and please also check your MTU size, the MTU size from the NIC

card should be a 64 Byt smaller then the supported MTU in your ADSL modem, if your nic card MTU sice is to big the modem must fragment the packets which bring the speed down.

hope this helps. But you can check this wire shark make a trace and upload it hear and i will look at it.

regards

Chris

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.