I have a Virtual PC VHD that I downloaded from Microsoft here: http://www.microsoft.com/en-us/download/details.aspx?id=11575 This VM instance is for IE9 testing, and it contains Windows 7 Ultimate (32-bit).

In this VM instance, I can not play avi files (I haven't tried other video types) through embedded Windows Media Player in the IE9 browser supplied. Well, they play, but the video portion is completely black. Some type of overlaying isn't working right. I mean, we are talking HTML as simple as this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<object id="mpVideo2" width="100%" height="100%"
  <param name="URL" value="http://SERVER_NAME/THE_PATH/split.avi">
  <param name="AutoStart" value="True">
  <param name="UIMode" value="full" />
  <param name="WindowlessVideo" value="True" />


Though, if you remove the WindowlessVideo param it works fine. But, we need WindowlessVideo set to true so that it works nice within our real app. Of note: split.avi is just a random avi I found on my computer that Microsoft supplies (it "splits" the Microsoft logo). I wanted to rule out any issues with our avi's and the codec's they use.

I have traced the issue to the DirectDraw Acceleration. If you run dxdiag, DirectDraw Acceleration, Direct3d Acceleration, and AGP Texture Acceleration are all 'Not Available', and there are no Enable/Disable buttons.

I did find this link: http://support.microsoft.com/kb/191660 and I went through the Methods, and Method 3 was to install the latest version of DirectX End-User Runtimes Web Installer (dxwebsetup.exe). I did this, and DirectDraw Acceleration is now Enabled (still no Enable/Disable buttons), but the other two are still 'Not Available'. This Method and the others did not help, the video is still black.

I'm wondering how you get the Direct X in a VM instance to work right.

I have another VM instance I use a lot, that I created a while back, that doesn't have any issues. Only DirectDraw is enabled (the others 'Not Available'). For my host machine, all three are enabled. The VM instance is running Windows Server 2003 Standard Edition, and my host machine is Windows 7 Professional (64 bit).

Virtual PC is

Here are the dxdiag screens for the display:

The host machine:

enter image description here

The 2003 instance that works fine (looks like only DirectDraw is needed):

enter image description here

The Win7 instance that makes me sad:

enter image description here

migrated from serverfault.com Aug 29 '13 at 15:17

This question came from our site for system and network administrators.

up vote 2 down vote accepted

You don't.

The Virtual PC display driver used in those virtual machines emulates an antique video card which has no 3D capability at all. Thus you cannot have hardware accelerated video, compositing, or any other such features.

If you need this functionality, consider Hyper-V or a VMware product.

  • Just to clarify, I'm slow, when you say "those virtual machines" you mean the specific ones from Microsoft? As, for example, the 2003 VM instance, that uses the same Virtual PC host, does allow the DirectDraw. And it works there (it looks like 3D isn't necessary, just DirectDraw). That's the thing that's throwing me off, I have a VM that does work (with only DirectDraw enabled) and one that doesn't work. How do I make the Win7 one more like the 2003 one? – JustLooking Aug 29 '13 at 15:22
  • 1
    You probably don't. Neither Virtual PC nor these drivers were really intended to provide significant graphics acceleration. – Michael Hampton Aug 29 '13 at 15:24
  • Scratch that (my previous comment) .. I thought his Win7 instance worked fine, but now I don't think so. It must be something about Win7 in a VM versus one of these older operating systems. – JustLooking Aug 29 '13 at 15:26
  • 1
    @JustLooking - Its important to point out that VMWare and Virtual PC 2007 are entirely different products. So the fact it works cannot discount the fact Virtual PC doesn't have the hardware emulation you require. – Ramhound Aug 29 '13 at 15:34
  • 1
    I think the point is, it's not supposed to work. That you get anything in the 2003 VM is a happy bonus, but it's not expected behavior. – Michael Hampton Aug 29 '13 at 15:39

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.