0

I'm using Print Management to install some network printers on a print server but the Windows Update button has gone missing from the Add Printer Wizard dialogue box. All I get is the Have Disk button. The Windows Update button should be right there next to it? I've searched the internet and I've found this info below but my Win8 machines already has those keys set correctly. I've tried several Win7 boxes in our network and they to have no Windows Update button. We do use WSUS to manage our Windows Updates but I dont see how this could affect that button?? I've tried disabling WSUS updates on my box but still no Windows UPdate button. Whatever it is it seems to affect every machine we have. I've looked at several GPO's and we have nothing set to disable the button.

Anyone else have any ideas, the internet is filled with others with this same issue but I havent been able to find any answers that help.

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DriverSearching Change value of REG_DWORD DontSearchWindowsUpdate to ’0′ Change value of REG_DWORD DontPromptForWindowsUpdate to ’0′

0

I had the same issue, but found it only occurred when I was trying to add a network printer. When I try to add a local printer the button shows up. So..... I installed a local printer, allowed Windows Update to download the new drivers and then deleted the local printer. Next I add the network printer again, but this time, because the list of drivers has been refreshed, I didn't need the Windows Update button because my printer is now in the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.