Is there a possible way to recover data on my Western Digital 2TB drive? I have tried different ways like using gparted and fdisk etc.. but nothing helped. The error I get is that it cannot find a partition table. I can create one but then it will remove all data on the disk which is not what I want. See printscreen what gparted says.

enter image description here

Any solution?

I thank you.

  • 3
    It's hard to answer your question without knowing how you lost that data... did you rm it? delete the partition? fill your /dev/sdb with zeroes? drop the harddisk out of the 30th floor? – replay Aug 30 '13 at 10:05

The most important rule of data recovery is do nothing that can change the data you have Creating a partition table is a bad idea, and fdisk and gparted are partition editors. They change the data and as such they risk destroying the data

I think we need to start with what actually happened to the data. If it was overwritten, it is very likely you are out of luck - modern drives are tightly packed enough that a simple one pass wipe irrecoverably deletes data.

If its a logic board failure, or some other low level failure, you will need a professional to swap parts and get it to work. You don't have the parts or the expertise. They might also have other tools at their disposal.

Lets assume you have the best case scenario - that just your partition table is malfed up.

Backup with a tool designed for recovery - I favour gddrescue. Then make a copy of your backup. Work off this copy. In this specific case testdisk should do the trick - you're working off an image so if something went wrong, all you did is munge up a copy of a copy of the data. Try other tools (kpartx works well for tools without native image support on linux) . DO NOT EVER WORK ON THE DRIVE YOU ARE TRYING TO RECOVER DIRECTLY

If all this seems alien, do as Tom O'Connor did and hire a professional or better yet, restore from the backups you should have been making.

  • Thanks for the explanation. No I wasn't creating a new partition table. That's why I didn't go on with it. I haven't recovered my data yet. The problem "cannot find cilinder"... keeps coming back. I've tried different things using Hirens Boot CD 15.. to recover the data. No success yet. When pluggin the drive (USB ) it shows WD but nothing else. The size of the disk is also recognized .. but nothing else. Thanks again for your anser. – holasz Aug 30 '13 at 13:17
  • "Cannot find cylinder" (what kind of an error message is that?) sounds like the drive is physically barfed. You may have some luck taking it out of the USB enclosure and hooking it up directly to the computer, but then again maybe not. Failing that, I'm afraid restoring from backup or consulting a professional data recovery services company may be your best options. – user Aug 30 '13 at 13:32
  • @holasz That sort of error indicates a problem with the drive hardware. This isn't something you will fix with software tools. Restore from backup, return the drive for a warranty replacement. Or if it has important data that you didn't backup for some reason, send it to a professional data recovery company. – Michael Hampton Aug 30 '13 at 14:40

If the data is truly valuable, then the only real solution is to ship it to a professional data recovery expert.

This process is expensive, and cannot guarantee that you'll be able to get the data back.

The important question to ask here is: If your data was so valuable, why do you not have a backup of it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.