I've got a Dell Latitude D620 that I just recently re-installed Windows 7 on. The BitLocker wizard reports the following error when I open it.

A compatible Trusted Platform Module (TPM) Security Device must be present on this computer, but a TPM was not found...

When I open the TPM Administration snap-in, it reports:

Compatible Trusted Platform Module (TPM) cannot be found on this computer. Verify that this computer has a 1.2 TPM and it is turned on in the BIOS.

So far, I have done the following:

  • Verified TPM was turned ON in the BIOS

  • Verified TPM was ACTIVE in the BIOS

  • Verified TPM Driver was installed and appears in the Windows Device Manager and that it reported it was functional

  • Verified there are no additional devices in the Windows Device Manager that do not have drivers, or appear as non-functional

  • Uninstalled the TPM driver (Windows 7 default driver) and selected Delete the driver software for this device and re-installed the driver using the one from Dell.com

  • Used the CLEAR TPM settings option in the BIOS

  • Turned OFF the TPM in the BIOS, rebooted, and turned it ON again

Something odd I noticed is that the TPM device does not show up under Security devices in the Windows Device Manager, it shows up under System devices. I recall it it being under Security devices in the past, and a couple of Google results confirm it should appear there. Is there anything else I can try to get this working? BitLocker is a company requirement, so I really need to get this working.

Note: Before re-installing Windows 7, I had BitLocker enabled on this same PC without any issues. So, I know the TPM is compatible.

  • I would request assistance with this problem from your IT staff they are in a better position to resolve this problem. – Ramhound Aug 30 '13 at 16:58
  • 9
    I am the IT staff. – Drew Chapin Aug 30 '13 at 17:01
  • This the same image you use on the rest of the equipment? I would simply start over if I were to encounter this problem. – Ramhound Aug 30 '13 at 17:03
up vote 6 down vote accepted

I was able to resolve the issue. It seems Windows had many driver options to chose from and was using the wrong one. Here are the steps used to solve the issue.

  • Open the Windows Device Manager
  • Go to System devices
  • Right click on the TPM device
  • Select Update Driver Software...
  • Select Browse my computer for driver software
  • Select Let me pick from a list of device drivers on my computer
  • Select the Broadcom Trusted Platform Module (A2), v1.2 (v1.2 is very important!)

After suffering the same issue on a Dell XPS 13 (Even going so far as to redo all the drivers, check BIOS, etc. I couldn't fix this). I found my solution deep on some microsoft forum, elsewhere.

I opened up the computer (laptop in this case), disconnected the battery from the board, held the power button down for 10-20 seconds to discharge the capacitors, and put it all back together. I managed to get the system to read the TPM device!

As someone who came here looking for the answer originally, maybe this will help others in the future. Huzzah!

  • This was the final step for me, too. Dell E7440. I had to do a BIOS update from version A11 to version A21 first. That made the TPM module reappear in the Devices control panel, with the correct driver, but re-enabling BitLocker still failed. After shutting down, pulling the battery, holding the power button for 20 seconds, then putting it back together and restarting, everything was good. – rhsatrhs Aug 22 '17 at 16:36

Download the TPM driver from Dell's website and install it. That should fix the issue.

  • Thanks, but I should have clarified, when I said "Re-installed the TPM driver." I used the one from Dell's website. – Drew Chapin Aug 30 '13 at 16:41
  • cant hurt to uninstall it, reboot and reinstall it... – Keltari Aug 30 '13 at 16:58
  • 2
    Have you checked to make sure that the driver that is being loaded for the TPM device is the correct one (the Dell one you reinstalled) through the device properties? It being shown under the wrong category leads me to believe a Windows/generic driver got loaded for it. – Moses Aug 30 '13 at 19:13

How to disable Trusted Platform Module (TPM) in BitLocker: Open Group Policy Editor:

If Group Policy Editor appears to be unavailable, follow instructions for enabling BitLocker first.

Open Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > BitLocker Drive Encryption > Operating System Drives.

Edit Require additional authentication at startup policy.

Set the policy to Enabled and make sure Allow BitLocker without a compatible TPM is checked. BitLocker on Windows 7/Vista does not support passwords for system drive if TPM is unavailable. If you do not like to use USB Startup key or memorizing BitLocker Recovery Key (which can be used like a password), upgrade to Windows 8 or later which supports passwords for system drive even if TPM is unavailable.

Source: http://truecrypt.sourceforge.net/NoTPM.html

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.