0

recently changed the bind file adding some comments with the character "#" which is the wrong one I guess because since the my website is inaccessible.

So I change it back, incrementing the serial number but by error I've incremented it to the 32 instead of the 31 but It shouldn't pose any problem. It's been two hours and it's still doesn't work.

Did I miss something ? I'm starting to get quite worried :(

PS : of course I reloaded the bind server every time.

Edit : I've also done the command bind -v by error, I don't know it's effects.

Edit : My predecessor didn't configure the bind log files so I tried to, my named.conf.options file is :

options {

    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

    // If your ISP provided one or more IP addresses for stable 
    // nameservers, you probably want to use them as forwarders.  
    // Uncomment the following block, and insert the addresses replacing 
    // the all-0's placeholder.

    // forwarders {
    //  0.0.0.0;
    // };

    auth-nxdomain no;    # conform to RFC1035
    listen-on-v6 { any; };

    listen-on { any; };
    allow-recursion { 127.0.0.1; 213.186.33.199; };

    allow-query-cache { 127.0.0.1; 213.186.33.199; };
    additional-from-cache no;
};

logging {

    channel default_log {

        file "/var/log/bind/error.log" versions 3 size 5m;
        severity warning;
        print-time yes;
        print-severity yes;
        print-category yes;
    };

    category default{
    default_log;
  };
};

But my logs are empty...

Edit : here is my db.domain.com file :

$TTL    3600
domain.com.       IN      SOA     serverid.kimsufi.com. myemail@gmail.com. (
                        2013090101  ; Serial
                        1200        ; Refresh
                        180     ; Retry
                        2419200     ; Expire
                        3600 )      ; Negative caching TTL
;
;NAMESERVERS
;
                IN      NS      serverid.kimsufi.com.
                IN      NS      ns.kimsufi.com.
;
;Nodes in domain
;
imap            IN      A       IPSERVER
domain.com.       IN      MX      10 mail.domain.com.
domain.com.       IN      A       94.23.52.112
mail            IN      A       IPSERVER
mysql           IN      A       IPSERVER
pop             IN      A       IPSERVER
pop3            IN      A       IPSERVER
smtp            IN      A       IPSERVER
sql             IN      A       IPSERVER
www             IN      A       IPSERVER
;
;Subdomains
;
subdomain1          IN      A       IPSERVER
...
subdomain12          IN      A       IPSERVER
;*.domain.com.    IN      A       IPSERVER
7
  • Having a look at /var/log/syslog might help, since bind usually drops its errors over there AND will even tell you, which line in your file is buggy. – vautee Aug 31 '13 at 15:26
  • I checked my bind9 on wheezy, there's no logging configured in /etc/bind/*, so just try and remove that part from named.conf and restart (not reload, this time, just to be safe) your bind9. – vautee Aug 31 '13 at 15:35
  • Done, no change at the moment. Do you have by any chance a file named.conf.log ? – bash_profile blank Aug 31 '13 at 15:40
  • I think the default log target is syslog, at least on Debian. – user1686 Aug 31 '13 at 16:15
  • I've got Aug 31 18:27:51 ks3098028 pop3d: LOGIN FAILED, user=admin@kimsufi.com, ip=[::ffff:202.149.117.38] Aug 31 18:27:51 ks3098028 pop3d: authentication error: Input/output error repeatedly with different user : spam@kimsufi.com, test@kimsufi.com, ... – bash_profile blank Aug 31 '13 at 16:24
0

Well, I still don't understand the problem, but I changed the name of my db.domaine.com file, created a new one, paste the content in it and well it's rolling again !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.