I'm having a problem with installing Visual Studio 2012 Premium (Professional and Ultimate too) under 64-bit Windows 8 Pro. When the 'acquiring' bar goes to 'Microsoft Visual Studio 2012 Devenv' I get an error.

Here is the screenshot: screenshot

"Nie mozna odnalezc elementu" means "Can't find element."

And here is the log: https://dl.dropboxusercontent.com/u/61787551/vs_log.txt

How do I fix this?

  • Try running the installer as administrator. (ie. Right click -> run as administrator)
    – user201262
    Aug 31, 2013 at 23:02
  • if G:\ your DVD/mounted ISO drive? Is the ISo corrupted? Sep 1, 2013 at 6:00
  • G:\ is mounted drive with VS iso, and check sum is correct. Sep 1, 2013 at 8:57

2 Answers 2


Try running the installer as Administrator. If it does not help delete Visual Studio from Program and Features and run CCleaner, then try and install Visual Studio 2012 again with Administrator rights. But before you do anything try and install all the Windows 8 Updates (Control Panel -> Windows Updates -> Check Updates).

  • Hi, I tryed this and still cant install ;/. I checked updates and installed all of them. Runned CCleaner and its still gives me that errors. I tried to install VS 2013 Preview and it works(!). Then i tried to install VS 2012 and still not work (with/out VS 2013 installed). Maybe its something wrong with Microsoft? Sep 1, 2013 at 9:04
  • I do not think that something is wrong with Visual Studio 2012. Have you tried to find the denenv.exe file on your PC ? You should look where it is located and delete it. I think something is corrupted on your PC and that is why Visual Studio 2012 won't install. But if you can use Visual Studio 2013 than you are fine, it is better than 2012 even if it is a preview version. How many Windows Updates did you have to install ?
    – Devid
    Sep 1, 2013 at 9:16
  • I haved to install about 20 updates (I haved auto updates turned off by accident ;/). Now I'll try to install it on another (clean) computer and post results here. Sep 1, 2013 at 9:21
  • I think the problem is caused in the first place because of these 20 missing updates. Others had similar problems and reported that after updating windows, Visual Studio installed with no problems. Restart your PC, turn automatic Windows Updates ON, and check again for Windows Updates. If there are no Updates try once more to uninstall completely Visual Studio 2012, search the web how you can uninstall it completely/everything and then download Visual Studio 2012 again and run the installer with administrator rights. Hopefully you won't see the error anymore.
    – Devid
    Sep 1, 2013 at 10:34
  • I tried to install it but it showing me "Unable to locate package source" I can select "Download from the internet" or "Provide a location to search for the packages" And this is path that comes up: C:\Users\JA\Download\packages\vcRuntimeDebug_amd64\cab1.cab (the 'packages' folder does not exists) When I select to download from the internet its showing up again after some time, I searched for "vcRuntimeDebug_amd64" folder but it doesn't contain "cab1.cab" file ;/. Sep 1, 2013 at 10:36

Go to Visual Studio downloads (http://www.visualstudio.com/downloads/download-visual-studio-vs) and install Visual Studio Express 2013 for Windows (from web or .iso)

This install also Blend for Visual Studio, but take care that require Windows 8.1, and from my experience will not install on the Preview (or trial) version of Windows 8.1.

Then you have to register Visual Studio Express with the 30 days of trial, in order to use it after this.

Hope it helps you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .