10

After removing the Phpstorm directory from Ubuntu, future installation attempts do not actually install any more - no menu item appears under Applications in the top left, and running the "globally created executable (I presume the one added in /usr/bin?) just runs the installation again.

Clearly there are some files hanging over that I need to get rid of, but I don't know which ones.

I 'installed' Phpstorm on Ubuntu 13.04 by doing the following:

  • Installing Oracle JDK 8
  • Downloading the tar.gz file to my ~/Downloads dir and extracted in the same dir
  • Running bin/phpstorm.sh

I decided that I had installed it in the wrong location, so I ran the following to remove it:

rm -rf ~/Downloads/phpstorm-version-whatever

Now, I'm stuck with the issue described above. The Phpstorm forums do not actually contain any docs or other people with the same issue.

How can I completely remove Phpstorm from Ubuntu, and start again from scratch? What files do I need to remove that are specific to this software?

7

You usually can't uninstall files installed without your package manager by just deleting the directory you extracted, though this often is actually true of Java based archives.

I don't know phpstorm specifically, but I can give you some generic instructions.

The very first thing I'd recommend you do is check if phpstorm itself includes some kind of uninstall script. I'd guess you already did, though.

Failing that, you should open a terminal and type whereis phpstorm - this should tell you where most of the files associated with it are located. You could then try deleting them manually. /etc and /usr/share are also some likely places to look.

You could also search through the hidden files in your home folder for one called .phpstorm or the like. This would probably contain most of the configuration and I don't think would show up with the "whereis" command.

That's all I can think of off the top of my head if the shortcuts and the like are already gone, but it might do the job. This is a messy and ugly way of doing things and may well leave something behind - try to install with your package manager whenever possible.

| improve this answer | |
  • 1
    Thanks Dylan, your generic advice (including the whereis phpstorm) was very helpful. An addition: In the home dir is a config / settings folder along the lines of ~/.WebIde that needs to be removed as well. – James Sep 3 '13 at 9:38
  • 1
    TO find the related directories in your home directory, run the command find . -type d -name 'WebIde'. On my mac it produces 4 results ./Library/Application Support/WebIde70 ./Library/Caches/WebIde70 ./Library/Logs/WebIde70 ./Library/Preferences/WebIde70 – Eddie Jaoude Nov 25 '13 at 5:31
7

Please remove the main folder and ~/.PhpStorm* folders. That should be enough.

sudo rm -R ~/.PhpStorm*
| improve this answer | |
5

On Ubuntu, after moving back to netbeans I also found traces of phpstorm hiding under ~/.java/.userPrefs/prefs.xml

| improve this answer | |
3

It is easy to completely uninstall any version of PHPStorm in Ubuntu by following these instructions.

  1. Enter your home directory.
  2. Here you see .WebIde100 (If it is hidden click Ctrl + H to show hidden files.)
  3. There open the terminal and delete this folder. The command is:

    sudo rm -rf .WebIde100/  
    
  4. Then install your new version.

| improve this answer | |
3

There is one other option. Maybe you've installed PHPStorm as a snap package. Then as snap packages, get mounted rather being unpacked, there is no folder you can remove. Then you have to use snap command to uninstall it. First check to see if its installed as a snap package:

sudo snap list

If you see PHPStorm in list, then you've to uninstall it using:

sudo snap remove PHPStorm

make sure to type PHPStorm's name exactly as is, regarding character case.

Say, one side effect that you may notice is that number of loop devices in your directory view is decreased, because now you have one snap app less than before. :-)

| improve this answer | |
  • 1
    It is called phpstorm (yes, all lowercase) on my Ubuntu 18.04.3 LTS install. Thanks! – doug65536 Aug 22 '19 at 11:44
1

A rm -Rf ~/.WebIde100 solved my problem. After that, when I restart PhpStorm, it asks me the activation code. Worked on Debian 3.16.7-ckt20-1+deb8u3

| improve this answer | |
0

newer version of phpstorm (2019+) you need find .Phpstorm{Version} directory under the /home/username/

Or simply use ls -ld .PhpStorm* it will output something like

.PhpStorm2019.2/

After that remove this directory

sudo rm -rf .PhpStorm2019.2
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.