5

Related to: When AC Power is disconnected, atibtmon.exe throws a Runtime error

I have a very similar configuration, ATI mobility Radeon HD 3670 on Dell XPS Studio 16 using Windows 7 64-bit, and have the same problem of atibtmon.exe throwing an error every time power is removed. The difference is, I do not have Catalyst Control Center installed and wish to avoid it as much as possible. It's a memory and CPU hog, and tends to leave corrupt installations which make deinstallation or upgrading a pain. So, I'm trying to find a way to do this directly, by whatever means CCC internally does it.

After some ack-ing and some googling, it looked like all I needed was to set a registry key PP_VariBrightFeatureEnable to 0. However, I've searched the registry all over (even with some regex-fu on Regalyzer ), but haven't been able to find such a key. I don't know where it's supposed to be so I'm unable to add it manually either.

Does anyone know the correct way to do this? The setup's .inf files have the string :HKR,, PP_VariBrightFeatureEnable which looks like the key goes somewhere under HKEY_CLASSES_ROOT (I'm assuming they're using an unconventional abbreviation of this one), but I'm not sure where exactly or even whether this interpretation is correct.

9

I added a value to the registry to this key: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000

The value name is PP_VariBrightFeatureEnable with the value type of DWORD and value 0x00000000.

Even though the value hadn't existed before, the brightness was constant after computer restart.

Hope this helps.

1
  • Thanks. I'd gone with the ugly hack of changing the atibtmon.exe's filename to something else, this is much cleaner. I'll try it out on my system after a restart. – sundar - Remember Monica Sep 12 '13 at 14:37
0

Sometimes the monitor itself has a setting for this (called DCR).
Set it to off on the monitor menu.

0

Maybe I'm a little late, but for newer AMD drivers, there's a different registry key controlling Vari-Bright. To disable it:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL3_DATA\power_v1]
@=hex:64
"abmuserenable"=hex:00

Set abmuserenable to hex:01 to enable it. There is another key abmlevel at the same level for controlling "Vari-Bright Level". The values are:

Maximum battery life: hex:04,00,00,00
Optimize battery life: hex:03,00,00,00
Balanced: hex:02,00,00,00
Optimize brightness: hex:01,00,00,00
Maximize brightness: hex:00,00,00,00

Notes:

  • AMD Vari-Bright is not the same as the brightness auto-adjustment that comes with Windows. Vari-Bright will adjust the gamma (!) according to your environment brightness which makes color on your display way less accurate (looks like color is washed out) and it is super-sensitive (triggers on average room lighting).
  • This method is tested on a Ryzen 7 4750U embedded graphics card, driver version 20.10.41.02-200916a-359311C-HP.
-1

In the Catalyst Control Center there is a setting to Enable Vari-Bright feature, uncheck it.

Click on Power...then PowerPlay and uncheck or click power express and uncheck automatic switching.

enter image description here

1
  • The post specifically says "without Catalyst Control Center" – Josh Comley Nov 20 '15 at 12:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.