I recently got a license for SecureCRT for the Mac from work and it's been great, but there are a few minor things that I'd like to get squared away with it. Some of them work on some nodes and not others, too, which makes it even more confusing for me. I'm running 7.0.4 which is the most recent the license I was assigned will permit. I've poked around in the settings, but the key mappings section seems to be blank by default and lets you override the defaults if you know what you need… but doesn't really help show you what the possibilities are.

  1. Option-delete: in most terminals, this ends up being equivalent to alt-backspace, which deletes from the cursor to the token preceding it. It's different than control-w in that it won't necessarily eat an entire word; if I have something like as-bb-cc and my cursor is at the end, alt-backspace will delete just cc (or possibly -cc, I can't remember off the top of my head). This is often times very helpful. When this does not work, the option key is ignored and it is treated as a simple backspace.

  2. Option-left/right arrows. I believe this is the equivalent of alt-left/right arrow, which allows me to jump word by word in the matching direction. No output is generated when I use this key sequence, and the cursor does not move.

  3. Fn-left/right arrows. This maps to the home/end keys, and works sometimes and not others. When it does not work, it sends a tilde (~) to the screen. This is always true on my local shell (command-l) but usually works fine if I SSH into my own machine.

  4. Occasionally on some nodes, the delete key is received as ^H, and backspacing actually has to be done via control-delete instead. This is somewhat rare but I'd like to know what to do when it occurs.


So I found answers to some of the problems.

1) Enabling Emacs compatibility so that the Alt/Option key became the Meta key allows for Option-backspace to function. Sadly this does not seem to fix #2.

3) This was a problem when terminal emulation was set to either VTxxx or Xterm. Switching to Linux emulation solved that issue. (This also solved some funky character issues that I thought was actually UTF8 related.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.