I was trying to copy files from a friend's damaged laptop. The hard drive still works, so I simply put the hard drive into a 2.5mm enclosure and connected it to my laptop via USB. The drivers installed fine, I was able to open up the root directory, and browsed to the "Users" folder. But when I tried to enter the particular user folder, it told me You do not have access to this folder. Click to get permanent access to this folder. Of course I did, and then after trying for an unusually long time (~2 minutes), it failed and the hard drive disappeared in my computer. (Note: The file system is not encrypted)

I also tried on Ubuntu Linux. This time, I was able to explore the user folder, but when I tried to copy files over, it waited a long time and then gave me a Error splicing file: Input/Output Error.

I found this question, which is supposed to work for XP. It points to this knowledge base article. Can I do essentially the same thing? (Both the damaged laptop and my laptop are Windows 7)

  • yes you can do the same, if you faced some troubles, please reply to my comment and I'll post an answer, but that link will fix it
    – Lynob
    Sep 3, 2013 at 13:31

3 Answers 3


Windows 7 also comes with takeown utility, which you can run against the second drive.

On a command prompt, switch to the 2nd drive, e.g.


Then run takeown

takeown /r /d y /f * 

Followed by icacls

icacls * /t  /grant Everyone:F

This was described in other question here on SuperUser.

  • Thanks, I will try it tonight and let you know if that fixed it
    – SSumner
    Sep 3, 2013 at 14:00
  • That didn't work. When I ran "takeown" as written it said The System cannot the file specified. for some files, and Access is denied for some others. It also said The current logged on user does not have ownership privileges on the file (or folder):
    – SSumner
    Sep 4, 2013 at 1:07
  • Did you run the Command Prompt as an Administrator?
    – Nasir
    Sep 4, 2013 at 16:02
  • yes, of course.
    – SSumner
    Sep 4, 2013 at 17:57

While the file system itself might not be encrypted, the files themselves could be encrypted.
I only know this from personal --and very frustrating-- experience. I had to boot into an earlier unencrypted Win7 installation and, through the properties dialog, unencrypt all of my user files before I was able to access them from the new OS.
You might want to try accessing the files through a live linux CD/usb. If you are not able to read the files from linux, you can be fairly certain that the files in question have been encrypted, at which point you'll have to unencrypt them in order for them to be of any use. Good luck.

  • I've tried that, and unfortunately it doesn't work
    – SSumner
    Mar 28, 2014 at 16:34
  • Are you saying you booted the hdd from your friend's laptop, or tried booting a live cd? Try booting the laptop hdd from a different computer....perhaps from your usb port. If it's successful, loo for highlighted green folders or files, then unencrypt them through the Properties->Advanced dialog. I know it's really frustrating!
    – blackappy
    Mar 28, 2014 at 18:22
  • Yep, both. I also tried both physically installing the HDD in my laptop and booting from there, and installing the HDD in an external enclosure. I'm also fairly sure none of the files are encrypted-I saw none of the highlighted green ones you refer to and the owner is not tech savvy enough or has reason to encrypt any files
    – SSumner
    Mar 28, 2014 at 20:12

If the HDD is giving you errors during long periods of disk usage, I would be worried about the integrity of the drive.

If the hard drive from the damaged laptop might also be damaged, it would be better to start by retrieving the most important files first without running anything that may cause a lot of HDD activity (such as takeown or icacls using * to do the whole drive).

You want to minimize drive activity until you get any crucial data off of it.

In your case, I would:

  1. Make a list of important data (most important goes first)
  2. Give yourself access to the first item
  3. Copy the data to another location

(repeat steps 2 and 3 for the rest of the items in the list)

You can use the takeown/icacls combo on a specific directory during this process, if you want, or you could just use the GUI option to gain access.

Your first attempt may have failed because of issues with the HDD, not issues with the process of gaining permissions.

  • His first attempt did fail because of the issues with the HDD, if he took ownership of the files ( which will cause havok if he trys to boot from the hdd ), hard to return ownership at this point. A copy of the HDD should be made, a program like Spinrite, might make it easier. Although based on the behavior its likely to late even Spinrite to help.
    – Ramhound
    Sep 3, 2013 at 14:53
  • Spinrite may actually "fix" the drive for awhile, but it would definitely be better to get important data off of the drive before doing ANYthing else. Spinrite is a great tool, but like anything else that causes a lot of activity, if there is a mechanical problem, it will kill the drive pretty fast.
    – Jaawn
    Sep 4, 2013 at 20:12
  • Better get the data now and replace the drive then do nothing and lose everything
    – Ramhound
    Sep 5, 2013 at 2:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .