Ok, I have a SanDisk 8gb flash usb pen.

I was using it nicely until VirtualBox (Meh.. oracle... messing up software since years) messed it up.

Basically this is what happened: I could use this usb pen correctly and see the files in it on this PC. I could use it on any other pc (I work as programmer, I put my hands on lot of PCs). Some days ago at home, I was using VirtualBox with Windows 8 on it and I wanted to try to plug in the usb pen drive to see if I could exchange data between the virtual machine and other PCs (long story about this particular choiche of transferring data).

What I did was go on virtualbox menu-->devices and click my usb.

From then, my usb didn't got recognised either by VirtualBox (I wasn't expecting anything more) and ALSO, from my desktop PC. I can use it with any other computer, see the files in it, cancel/write data, browse the folders, etc etc.

Tryed to uninstall the driver and plug it back, but nothing.

What's happening, and how can I fix it?

  • I wonder if removing the entry for that usb device from the registry will work. I'll dig around to find the location.
    – Ben Plont
    Sep 3, 2013 at 19:47
  • I recommend simple utility nirsoft.net/utils/usb_devices_view.html to uninstall that USB device. But I think that problem could be in VirtualBox USB filter driver rather than SanDisks.
    – week
    Sep 3, 2013 at 20:05

1 Answer 1



Open registry editor:

from the start menu or command prompt type regedit.exe

press ENTER

In the left hand panel navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

find the entry for the usb device in question.

Right click it.

from the context menu select delete. (OR Export to create a back-up in the location of your choice. I have a folder on my desktop called regFiles I use for back-ups).

Plug the USB device in to re-associate it with the host, hopefully this will reset the relationship. If that works, delete the back-up of the registry key you made before deleting it from the registry (you won't need the old one because it's created a new one).

In order to delete the registry key you need to set permission for yourself. You need to do this step for all subkeys.

right click the (sub)key select permissions from the context menu > select advanced. At the top, select the owner tab. select the account you want to give ownership to. click apply click ok. This should take you back to the security tab of the permissions click `owner rights check the box for full control. Click apply. Click OK. Repeat for all sub keys. (This may take a while, but once you take ownership of all the subkeys you can delete them.

(To save time, you can take ownership of all the subkeys, then at the main key go to the security tab of the advanced permissions window and select: Replace all child object permissions with inheritable permissions from this object)

enter image description here enter image description here

  • It gives an error "Cannot delete Disk&Ven_SanDisk&Prod_Cruzer&Rev_1.00. Error during the deleting process". Same goes for the subdirectories of that registry key and even for the similar ones. Access denied. And Yes, I'm administrator on this pc. Well actually my OS is in another language, but I translated into english manually... Sep 3, 2013 at 20:08
  • It a problem with permissions. I'll get the solution in a few minutes.
    – Ben Plont
    Sep 3, 2013 at 20:14
  • I updated the process.
    – Ben Plont
    Sep 4, 2013 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.