I have a Windows 7 virtual machine that I sometimes use for Windows-specific applications at my school. The host machine is running Fedora 19 and the virtualization program I'm using is VirtualBox.

Here is my problem: this semester, I am unable to access the internet on my virtual machine. I was able to before, but has been four months since I last attempted and there has since been an operating system reinstall, kernel upgrades etc. plus whatever changes the school made to their network so I don't know what that's worth.

I have tried accessing the internet by using a bridged adapter (my original configuration) and by using NAT. With the bridged adapter, I not only fail to connect but actually get kicked off the network on the host machine! I don't know if that's intentional or what. Both configurations work on my home network.

With NAT, the problem seems more manageable - I am able to connect to the network itself. However, Windows gives me a "No Internet Access" warning on the little network icon. I am able to ping Google's free DNS servers and the IP address I got from an nslookup of Google.com, but attempting to ping anything via domain name (as opposed to IP address) fails. This holds true even if I assign those very servers as my DNS servers.

I also tried doing an nslookup of Google and accessing the address I got through my web browser. This failed. However, I didn't have the chance to test any other sites so I don't know if that's an isolated issue. I'll do some further testing tomorrow if I can.

It seems unlikely that my school would be deliberately blocking virtual machines from accessing the network (if doing so in this way is even possible) - I've been specifically instructed to use them for classes in the past.

Does anyone have any ideas as to what might be happening and, ideally, what I can do to fix it?

  • There's certainly means by which they could prevent access if they had the proper hardware. Have you considered asking your school's tech department if any changes recently made would cause this? – user201262 Sep 4 '13 at 0:00
  • I've only just discovered the issue. I don't want to bother them about it until I'm fairly sure I can't fix it myself, so I'm going to test it out a bit more tomorrow. I wasn't aware one could prevent NAT routed DNS packets from within a virtual machine - wouldn't it just appear to be coming from my computer, which is working fine? – Dylan Sep 4 '13 at 0:56
  • That's true for NAT routing (which is likely while you're at least able to get LAN connectivity), but for Bridged mode, I wouldn't be surprised if a school had something in place to prevent unauthorized machines on a wired network based on MAC or something AD related. Is this your personal computer or the school's workstation? – user201262 Sep 4 '13 at 0:58
  • It's my personal laptop. No school implemented proxy or anything. I don't mind not being able to use bridged mode and could understand them restricting that - that's mainly for when I'm hosting services in VMs on my own LAN. – Dylan Sep 4 '13 at 1:01

I worked it out. It turns out that I had to manually set my virtual machine to use my school's DNS servers. I guess they disabled DNS queries to servers outside the network or something? Why the virtual machine didn't use the local DNS servers (i.e. the ones assigned to my computer by the school's DHCP) when it was set to NAT without static DNS servers is unknown to me.

| improve this answer | |
  • 1
    You gotta be kidding me, I suggested asking them if you could use their DNS servers, but I figured "nawww that can't be it" and deleted my comment XD – user201262 Sep 4 '13 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.