31

Hi this is a new problem that I did not have a few weeks ago.

I have a Logitech Illuminated Keyboard running on Mac OS X 10.6 (Snow Leopard).

The problem is that I cannot type a tilde. Instead when I press the tilde I get this character:

§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§

I cannot for the life of me figure this out, except that I vaguely remember I can asked to redetect the Mac keyboard layout for this keyboard and I think i chose the wrong one.

Now I get this weird character when pressing tilde. How can I fix this? Or how can I redetect this keyboard layout? Thanks.

  • 1
    What keyboard (Input Source) is selected in "Language and Text" in your System Preferences? Of note the character you're printing can normally be inserted using Option-6 (the section character) – Chealion Nov 2 '09 at 1:57
  • 3
    On some Apple keyboards, a backtick/tilde key is left from "Z", on others it's left from "1" (and the other position is then "§/±"). And there's probably more options here. So: where is it on your Logitech keyboard? – Arjan Nov 3 '09 at 11:07
  • Makes me wonder: can you somehow still switch between application windows? (Command-Tab to switch between applications, Command-tilde to switch between the windows of an application)? – Arjan Nov 3 '09 at 11:24
  • Arjan: No i cannot command-tilde between windows. The character output doesnt work in any form for me. – Brock Woolf Dec 1 '09 at 16:56
  • @Chealion: Option-6 gives me: § - Nice try though – Brock Woolf Dec 1 '09 at 16:56

14 Answers 14

11

Don't know if you are still reading this but if you download a program called Ukelele, you can make custom keyboard maps.

Then you need to put the keyboard map into ~/Library/Keyboard Layouts/, log off and then back in.

Once you have done this you can choose your custom keyboard layout and you will be able to use the ~ key without any problem (I'm using a Logitech illuminated keyboard using the default Logitech-UK keymap that comes with Ukelele and everything works).

| improve this answer | |
20

On a keyboard with that "<>|" button between the left shift and Z, holding down Shift and pressing that button works on my end. Neither Alt-5 nor Alt-N do the trick on my end.

| improve this answer | |
  • Phew, that worked! I'm using a Danish keyboard and US layout. – Dmytro Shevchenko Jun 15 '13 at 21:54
  • I am using a Dutch keyboard with US layout, and this worked. – qed Jul 17 '14 at 22:19
  • On Swiss German keyboard with US layout the combination is ⇧+<> – klimat Mar 29 '19 at 21:08
16

If someone else is still interested in how to swap the § key with ~, I use Karabiner to do that and it's pretty easy to use. Just look for that option which is included in the default ones among others.

enter image description here

It can also be used to remap other keys if you want. For example, you can use hjkl keys to emulate the arrow keys (vim users will love it).

| improve this answer | |
  • +1 This solution worked straight away for me, it is the simplest solution ever, thanks!. On the other hand, using Ukelele didn't work for me, the keyboard layout bundle is not recognized. – Clint Eastwood Jul 28 '15 at 15:05
9

Usually ~ character is associated with "n" letter. So you can do ~ using "Option + n" keys.

When you do not know how to type a char, you should try the keyboard viewer in the last tab of the "langage and text" icon of the prefs panel.

| improve this answer | |
  • Protest ;-) There's no "Alt" in OS X. See superuser.com/questions/25005/… ;-) (Option-N followed by n or N can be used to get ñ and Ñ. But indeed, Option-N followed by space yields just ~. Still, Brock's keyboard layout does not match the actual keyboard.) – Arjan Nov 3 '09 at 11:04
  • Sorry, on french layout the "option" is also co-named "alt" – Luka Nov 3 '09 at 11:12
  • I edited the answer to take your comment into account. Thanks ! – Luka Nov 3 '09 at 11:15
  • on french layout the "option" is also co-named "alt" -- yes, on my Macs as well, but that's not used in OS X. Of course, it's not a real issue (let's get world peace first). See that link I gave for some thoughts on "Backspace" and "Alt". I actually hope that French keyboards have a tilde key as well? I can't live without it, like using Command-~ to switch between application windows. – Arjan Nov 3 '09 at 11:20
  • 4
    On my layout option + n produces a ˜, which is different to the tilde, which is ~ – Josh Hunt Nov 3 '09 at 12:23
6

The correct way to fix your problem is to get your Mac to re-detect your keyboard type.

Open your Keyboard preferences (System preferences → Keyboard) and on the bottom left side you will see a "Change Keyboard Type" button.

Keyboard - System preferences

Click on it and follow the instructions.

| improve this answer | |
  • 1
    this should be the accepted answer, and the best for mojave! – Agoston Horvath Dec 13 '18 at 18:03
  • Had the same issue, and this helped! Thanks a lot! – Sergii Bishyr Mar 6 '19 at 10:22
5

On a Mac, tilde can be obtained using the key combination Alt+5.

Let me stress that Alt+5 returns tilde ~, whereas Alt+n returns tilde as character apice ˜.

| improve this answer | |
  • You're right that Alt+n gives ˜ which is not the true tilde, but Alt+5 gives me ∞. I'm using the UK keyboard layout on an American hardware keyboard. – Timmmm Dec 24 '13 at 13:41
  • 1
    If you want the real tilde, try Alt+n and then press the space bar...your "fake" tilde will be converted to a "real" tilde ;-) – Clint Eastwood Jul 28 '15 at 15:00
4

What characters you get by typing with key, , or combination of the two (there's also , remember) depends on which language keyboard you use.

To find out all characters on your keyboard enable Keyboard & Character Viewer in Input Sources inside Language & Text.

With U.S. keyboard type ` (near the left Shift button).

| improve this answer | |
4

With Karabiner-Elements, it can be done by swapping non_us_backslash and grave_accent_and_tilde keys like so:

Karabiner-Elements Simple Modifications screenshot

I needed this setup for my German keyboard which use with both English and German layout.

| improve this answer | |
  • This worked for me - I would never have stumbled upon non_us_backslash - the other option key solutions won't work for me as I use both '`' and '~' all the time. – bloke_zero Jul 20 '18 at 8:47
2

On my macbook air with Danish keyboard layout, ~ key combination is alt + ^.

| improve this answer | |
  • Works with a Swwedish (external) keyboard connected to a Mac Book Pro. – Johan Karlsson Oct 21 '13 at 8:29
  • Does not work with UK keyboard layout on US hardware keyboard. – Timmmm Dec 24 '13 at 13:42
2

In my case, on OSX 10.9.1 ~ on my German Airbook using US American layout is mapped to Shift and the key directly to its right.

| improve this answer | |
0

In my MacBook'07 keyboard I get the ~ by combining "Shift" + "`" (the next key to the right).

| improve this answer | |
0

I set up KeyRemap4MacBook application and type ~ with shift+escape

setting tilde key to shift escape in KeyRemap4MacBook

| improve this answer | |
0

And for those amoung us using a mac keyboard with Spanish keyboard layout, ~ key combination is alt + ñ (the Spanish ñ, instead of n).

| improve this answer | |
0

The best and easiest way is:

  1. Shift+` Obs.: Between left Shift and z

  2. Then s p a c e

show on keyboard

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.