When connected to a network (wia wifi), the webserver (IIS 7.5 on Windows7) on localhost takes up to 30sec to respond. Same for or the internal ip ( When disconnected - I get a the website from localhost loaded within 1sec. WTF?

As I modified routes for a VPN yesterday, I suppose I destroyed something in the routing table. But to me it all looks fine...Any ideas? I also tried adding "127.0.01 localhost" to the hosts file and disabling IPv6 without avail...Here is the routing table when connected:

Interface List

    11...88 53 2e 00 8d 4a ......Intel(R) Centrino(R) Advanced-N 6230
    1...........................Software Loopback Interface 1
    15...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface

IPv4 Route Table

Active Routes: Network Destination Netmask Gateway Interface Metric    286         On-link    286         On-link    286         On-link    286         On-link    306         On-link    306         On-link    306         On-link    306         On-link    306

Persistent Routes:

Network Address Netmask Gateway Address Metric  Default

IPv6 Route Table

Active Routes: If Metric Network Destination Gateway

    15     58 ::/0                     On-link
    1    306 ::1/128                  On-link
    15     58 2001::/32                On-link
    15    306 2001:0:5ef5:79fd:3cb9:3333:a488:5e63/128 On-link
    15    306 fe80::/64                On-link
    15    306 fe80::3cb9:3333:a488:5e63/128 On-link
    1    306 ff00::/8                 On-link
    15    306 ff00::/8                 On-link

Persistent Routes: None

  • is defined as localhost in every version of Windows by default. What do you mean you defined it exactly? Try changing the routes on the VPN back to what they were. – Ramhound Sep 4 '13 at 14:03
  • I found some suggestions to redundantly add the host name "localhost" pointing to the loopback IP in the Windows\System32\drivers\etc\hosts file. But as the issue exists with browsing the IP directly this can't be related... – Elementenfresser Sep 4 '13 at 15:28
  • I don't understand what 2 entries for the same ip address is suppose to do. The entry you describe already exists by default out of the box. – Ramhound Sep 4 '13 at 15:47
  • by default localhost is commented out in the hosts file in Windows7. And some users with issues like mine porposed to uncomment it there...but it didn't help anyway. But i'm quite sure it must be an IP issue, not a NS issue... – Elementenfresser Sep 4 '13 at 17:35
  • My personal experience using a default installation is that is defined as localhost and not commented. Besides there are many programs that assume localhost is defined – Ramhound Sep 4 '13 at 17:40

Well actually the issue was not related to the routing table. The web application itself tried to query the Active Directory server in the Role Provider's GetRolesForUser(string username). Since the AD was not there when not connected via VPN - every request timed out and failed resulting in overall response times of about 30 sec. Interstingly, the AD request did not happen at all when the server was disconnected from ALL networks and therefore responded fast.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.