10

I have a Windows 8 laptop, which is usually on 24/7. Often I connect to it with TeamViewer and work remotely. I realized, that when I use Chrome, the pages do not update/render unless I switch to another tab and then back to the one I need. That made Chrome unusable and I had to browse with Firefox instead. Remote Desktop, however, doesn't cause this.

What could be the reason?

8

Oleg's answer seems to be the problem, here's the solution.

http://www.helping-squad.com/fake-connect-a-monitor/

Basically, go to "Control Panel > All Control Panel Items > Display > Screen Resolution", tell it to detect additional monitors, then click on "Another Monitor Not Detected" and specify a "Mobile PC Display" with the same resolution as your native monitor, and finally set your display to duplicate your display on both monitors. Now when you close the lid, the phantom monitor keeps your acceleration working.

Seems to be working both for Chrome and for the accelerated display widgets in Windows.

  • Sir, you saved my day :) – Patrick Bard Jul 30 '15 at 11:55
15

I've contacted TeamViewer support regarding the subject and turned out that this was due to how Windows 8 handles a closed lid. Anything, what requires GPU processing, wouldn't get rendered at all, if there's no active monitor (and a closed lid is basically the same as if it was disconnected).

The fix is to disable hardware acceleration in Chrome settings:

Hardware acceleration

Remote Desktop works because it virtualizes everything (while TeamViewer just captures the screen).

  • 1
    Thanks man, just got stumbled upon it, neither chrome or virtualbox in remote machine worked, now it makes sense – maurycy Aug 1 '14 at 9:52
  • Thanks, after implementing this, Chrome now works with the lid closed. Spotify still has the same issue as before. How could I fix this? (I'm running Windows 10). – Eric Auld Dec 7 '15 at 2:02
5

For anyone else in a bind like I was that finds themselves here, you may have found yourself running into this issue without the benefit of physical access to the device at the time. It is rather difficult to change a setting if you can't get Chrome to render anything.

As a solution, you can right-click on your Chrome shortcut. Select Properties. Now copy the value in the Target field. Press Windows Key and search for cmd.exe. After opening the command prompt, type cd into the window. You will have to right-click to paste the value you copied from the properties tab. Delete chrome.exe from the end of that line, but do not forget to leave the quotation marks after you do so.

The text to the left of the > should change to what you had in quotes after cd. You need to make sure Chrome is not running in the background before entering the next command. You can do this by opening Task Manager and making sure Chrome is not listed. If you see a lot of Chrome entries, ending the one using the largest amount of RAM should kill all the others without you having to stop them one by one.

Now copy the following and press enter. chrome.exe --disable-gpu

Now remember me next time you stumble onto something that leads you to solve an issue and take the time to make the search easier for the next person.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.