12

This error code is supposed to mean 'Access Denied', and the solution given everywhere on the net (eg. https://stackoverflow.com/questions/3808954/dllunregisterserver-failed-with-error-code-0x80070005) is to open a cmd with Administrator rights. However, in my case, the same error occurs even on a cmd opened with admin rights (tested with the answers on https://stackoverflow.com/questions/7985755/how-to-detect-if-cmd-is-running-as-administrator-has-elevated-privileges).

Both

regsvr32.exe "C:\Program Files (x86)\GitExtensions\GitExtensionsShellEx64.dll"

and

 C:\windows\SysWOW64\regsvr32.exe  "C:\Program Files (x86)\GitExtensions\GitExtensionsShellEx64.dll"

fails with the same error message, that the given module was loaded but the call to DllRegisterServer failed with the code 0x80070005.

I tried to monitor registry accesses as given in http://www.cryer.co.uk/brian/windows/troubleshooting/nt4_dllregisterserver_in_com_failed_0x80070005.htm , but there are no ACCESS DENIED or ACCDENIED results at all in the resulting list.

Edit: I've now even tried

runas /user:Administrator "regsvr32.exe \"C:\Program Files (x86)\GitExtensions\GitExtensionsShellEx64.dll\""

from within a cmd that was itself run as Administrator but that too results in the same error!

  • If you move the file to a non-protected folder does it work? – Ramhound Sep 4 '13 at 15:48
  • @Ramhound Unfortunately yes, the same happens wherever I put the dll files. – sundar - Reinstate Monica Sep 4 '13 at 15:58
  • use ProcessMonitor instead of regMon to monitor the activity. – magicandre1981 Sep 4 '13 at 18:17
  • @magicandre1981 Yes, I read that regmon had been merged into procmon so that's what I used. I made a filter to observe only regsvr32.exe to filter out the (tons of) noise, and also made it show only registry changes. There were many SUCCESS, REPARSE and NAME NOT FOUND results but no ACCESS DENIED. – sundar - Reinstate Monica Sep 4 '13 at 18:24
11

Run the regsvr32 command from an elevated Command Prompt.

Select Start > All Programs > Accessories', then right-clickCommand Promptand selectRun as administrator` from the context menu. Finally, type the command.

  • 4
    And if the error persists... ? – bigp Jun 6 '16 at 12:35
  • @bigp perhaps then the entries in registry are already removed or somehow faulty – serup Nov 20 '18 at 7:17
0

The error 0x80070005 means Permission Denied accessing the folders or files (usually cache files).

Go to /Users/Public/Application Data/Package Cache folder and make sure that the folders there has the right permissions, otherwise remove them and re-run.

Same when using wine, e.g.

chmod -v 755 ~/".wine/drive_c/users/Public/Application Data/Package Cache"/*

Otherwise check the log file for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.