I receive an error while powering on a VM:

Unable to open file "D:\Virtual Machines\Red Hat Enterprise Linux 6\Red Hat Enterprise Linux 6.vmdk":

Insufficient permission to access file.

My system: Windows 7 32-bit with VMware Player.......some days it works but I (edited) did services run manually? Now am getting above error. What can I do?

  • have u tried starting virtual machine with admin permissions? – BlueBerry - Vignesh4303 Sep 5 '13 at 6:17
  • fixya.com/support/… I found the solution on another web site .It will help you. – user376879 Oct 9 '14 at 9:49

Same error, I had taken over the PC from a past developer and tried local Admin logon, no help.

I first tried setting 'Full Control' security permissions in Properties for the project and file it was complaining about, no luck.

So I went up to the parent dir of all the VM's on the box, set 'Everyone' full control, and the VM opened right up.

I encountered the same issue, and neither 'Full Control' security permissions, nor running as admin fixed it.

It turned out the "Read-only" attribute of the file was checked and I only needed to uncheck it to fix it.

This read-only attribute tends to be set automatically when you burn the file on an optical media or when using disk imaging tools like Win32Disk Imager

run virtual player as an Administrator

  • 3
    Though this could be a solution it is better to change access rights of the files. – pabouk Oct 18 '13 at 8:11

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.