I want to make DBAN bootable from a UFD (USB Flash Drive). I have the ISO image (dban-2.2.7_i586.iso) and I am using a tool called Rufus (rufus_v1.3.4.exe).

I first tried using the default settings. It didn't work. It gets stuck at "Verifying DMI Pool Data". The keyboard cursor is blinking but it's like nothing is loading, and I can't use Ctrl+Alt+Del to abort and reboot. I have to use the Reset button.


I then tried copying the ISO again, this time enabling the option "add fixes for old BIOSes (extra partition, align, etc.)" because it says that this can help with boot detection for old BIOSes. This didn't help. At "Verifying DMI Pool Data" it just skips it when the boot fails and goes on with booting from the regular hard disk with Windows.

  • Consider putting sysresccd.org on your drive, it includes dban in addition to other tools. It has a nice setup tool.
    – Zoredache
    Sep 5 '13 at 18:06
  • @Zoredache I have SystemRescueCD (SRCD) 3.7 and I can't find it. Can you tell me how to access DBAN in SRCD? Do I have to access it from the command prompt? Also, shouldn't it be listed on the Detailed-packages-list if it was included? I can't find it. Please quote your source. All I can find is some old threads that mention DBAN on the SRCD forums.
    – Samir
    Sep 5 '13 at 21:10
  • @Zoredache I did find this manual page in German. It says you have to call it from the command line, by typing dban in Terminal I guess?... Perhaps it has been removed in latest version of SRCD?
    – Samir
    Sep 5 '13 at 21:15
  • 1
    Choose Option A from the boot menu. DBAN will be on the list. Unless it got got changed/removed on 3.7. I have a 3.6 disk, I am downloading the new version. i.imgur.com/x4y9dBa.png
    – Zoredache
    Sep 5 '13 at 21:22
  • @Zoredache Thank you! I found it, it's available in version 3.7 as well. I just wasn't using the correct menu (option A on boot screen). Like I said in a comment below I did manage to burn the ISO file to UFD using the Universal-USB-Installer, and it would boot into DBAN but selecting the drive to wipe and hitting F10 to begin a short DOD scheme wipe resulted in errors. Ultimately I even tried burning the ISO to a CD and boot off of that, as it was intended, I still got the errors right after starting the wipe process in DBAN.
    – Samir
    Sep 6 '13 at 9:14

Have a look through DBAN's forums. This thread, has some suggestions:

The USB drive needs to be setup with a single FAT (not FAT32) partition, any extras like U3 need to be removed.


You need to specifically run the .exe with Administrator rights. In Windows 7, do this by right-clicking the .exe and choosing "Run as Administrator".

There is also a howto over on pendrivelinux.com.

  • The DBAN Source Forge discussion forum suggests using an EXE file to create a bootable UFD with DBAN. I can't find any EXE files on the DBAN SOurce Forge files section. There are only ISO files and TAR inside BZ2 files (e.g. dban-2.2.7_src.tar.bz2). I will try the Rufus tool again, but just make sure the file system is FAT and not FAT32.
    – Samir
    Sep 5 '13 at 17:06
  • @Sammy I had understood it to mean that you should run Rufus as an administrator.
    – terdon
    Sep 5 '13 at 17:12
  • There is a Windows shield icon on top of the Rufus EXE file. It makes UAC prompt for permission. Isn't that the same as running as admin? I just tried using FAT but it was to no avail.
    – Samir
    Sep 5 '13 at 17:25
  • They specifically refer to dban-1.0.7_i386.exe in the thread you linked to. This is a DBAN file, and it has nothing to do with the tool I am using (rufus_v1.3.4.exe) to burn the ISO to the UFD. This file is nowhere to be found on the projects Source Forge file repository section. But it's no wonder, this discussion thread is from 2009. My guess is that they removed any EXE files, DBAN is now distributed only as ISO file or in compressed TAR.BZ2 file.
    – Samir
    Sep 5 '13 at 19:14
  • I tried another tool called ISO to USB and this didn't work either. During POST I normally press the F10 key to get the boot options and choose USB-HDD. After using this tool the boot didn't get stuck like with the Rufus tool. Instead, right after "verifying dmi pool data" I got the message "Ta bort flyttbara diskar. Tryck ned en tangent för omstart". It's just saying remove any removable disk and press a key to restart. Removing the UFD and hitting Enter just boots into Windows.
    – Samir
    Sep 5 '13 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.