I have imaged a Dell Optiplex 755 with Windows 7 32-bit, at random, the mouse buttons swap themselves over. This is rectified when the user logs off and logs back on. The reg entry for the mouse is NOT changing from 0 to 1 so it's not registry related. Didn't have this problem with Windows Vista previously.

I have updated the chipset to the latest version, released in 2010. It's not happening on a Dell 7010 with the same image.

Multiple users are experiencing this and I have not found a solution yet.

Any ideas folks?

Many thanks

  • Have you tried moving the mouse between the two systems? It seems like you're assuming that this is a software issue, but maybe the mouse is swapping the clicks sporadically? – ernie Sep 5 '13 at 18:52
  • I am assuming it's a software issue as the buttons revert back to normal when the user logs back on. I've tried different mice too. There has not been any specific SetPoint or other software installed for the mouse as the image was built on a VM. Puzzling! – user251700 Sep 6 '13 at 8:21
  • Are you saying that if you use different mice on the system that swaps buttons, that those mice end up with swapped clicks as well? I missed the VM bit before - are the mouse clicks in the host still tracked correctly? – ernie Sep 6 '13 at 16:51

Go into your Mouse Properties from the Control Panel and tick the option that says Switch primary and secondary buttons, apply the change and then change it back (use right click when changing back). It might help the mouse "remember" how it should function.

  • I've set this as an admin on the machine, but the next time a user logs on, the same behaviour can be seen. There is no set action to re-create this, just clicking around on the desktop can trigger it. – user251700 Sep 6 '13 at 8:24
  • You could try re-installing the mouse drivers. – Yass Sep 6 '13 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.