11

I have Windows 8, and none of the metro UI apps were working, so I downloaded a registry fix from Microsoft. I ran it, and during that time I ran Windows Update. I restarted the PC, and after the boot screen with the Windows 8 logo, it never showed the lock screen, just a black screen.

I force restarted the computer several times, checking whether the problem still occured and it did. I attempted to fix this problem by running my windows installation disc. I clicked Repair, Troubleshoot, Advanced Options, then system restore, as I had a backup from a few days ago.

A window popped up:

To use System Restore, you must specify which Windows Installation to restore. Restart this computer, select an Operating System and then select System Restore.

After encountering this error, I tried to refresh and reset my pc. The error message for Refresh PC:

The drive where Windows is installed is locked. Unlock the drive and try again.

So I cancelled, and tried Reset PC. Error message:

Unable to reset your PC. A required drive partition is missing.

I have not made any changes to the hard drives recently, unplugged them or any physical changes to the computer. I have access to CMD from the repair disc.

Can anybody identify the problem, and how I can refresh by unlocking the hard drive, or use System Restore?

7

Erasing the system is not what you want!

To make the system boot again, you need to fix the EFI boot stuff. It's related to messages like

The windows boot configuration data file does not contain a valid OS entry
The drive where Windows is installed is locked. Unlock the drive and try again.

Follow these steps - see this blog

  1. Use a Windows DVD (or USB Stick) to open a repair command prompt.

    Troubleshoot -> Advanced Options -> Command Prompt

  2. Execute these steps - do not enter the comments. But adjust the numbers and the Windows path to match your configuration.

    // start the disk partition tool
    diskpart    
    // if you have more disks find the correct disk and use its number
    sel disk 0
    // if you have more disks find the correct disk and use its number
    list vol
    // the drive where EFI is on is usually the first FAT32 volume - here 2
    sel vol 2
    // make that volume accessible
    assign letter=z:
    // leave the partition tool
    exit  
    // navigate to the EFI stuff
    z: 
    cd z:\EFI\Microsoft\Boot\
    // fix the boot record
    bootrec /fixboot
    // restore the boot menu - adjust the path to match your windows location
    bcdboot c:\Windows /s z:
    

This is what worked for me.

4
  • 1
    Note that you may have to adjust the drive letters as well as the numbers (i.e. your C: may not actually be C: when you're in the setup command prompt, etc.) -- also if you don't know what drive numbers to use, you can try list disk or list partition in DiskPart. – BrainSlugs83 Sep 13 '15 at 18:24
  • 1
    This worked beautifully for me! I had imaged my C:\ boot drive to an M.2 SSD (native Skylake) and it looks like the imaged drive still had magic EFI boot stuff on it gunking up the works, causing me to get the The Windows Boot Configuration Data file is missing required information error. Following your diskpart and bootrec and bcdboot commands fixed it perfectly! – Jeff Atwood Sep 18 '15 at 23:56
  • @bebbo - Why are you rolling back to revision 1 of this answer? The edits made by Jeff needed to be done. – Ramhound Nov 2 '15 at 14:16
  • I got all the way to bootrec /fixboot, and that's where I got an error saying "Access is denied." Now what do I do??? – jp2code Nov 12 '20 at 0:56
-4

My answer was wrong, unless your PC HDD is BIOS locked (encrypted). You want the other answer, probably.

This may or may not be doable for you, but it will almost definitely work. IT WILL ERASE ALL INFORMATION ON THE DISK.

  1. Boot to a linux distro from a live USB or DVD/CD.

  2. Open gparted, or if it isn't installed, install and open gparted.

  3. Format your disk with NTFS from there.

  4. Reboot and try to install windows again.

If the above doesn't work, I have one other solution. This one is more dangerous.

  1. Boot to a linux live USB/DVD/CD.

  2. open a terminal.

  3. type mount to check what device your hard disk is mounted as.

  4. run sudo dd if=/dev/zero of=/dev/{device name, as shown by 'mount'}

  5. No output will be displayed, but rest assured it is working. It is replacing every bit on your HDD with a zero.

  6. When dd exits, try booting from the windows install DVD again.

2
  • On a more personal and opinionated note, you should never use Windows 8 unless forced. It has been a nightmare to make it work with any hardware I bought over the last ten years. I am back on 7, but still running Arch Linux as my main OS. – Wyatt Ward Dec 13 '13 at 23:08
  • I rebuilt my computer from scratch from parts made this year. I probably won't get affected by hardware issues, but thanks :) – Anthony Dec 20 '13 at 15:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.