1

I tried to install wget version-1.14 (tar.xz package) on cygwin, but it failed. My steps were

tar -xf wget-1.14.tar.xz
cd wget-1.14
./configure 

After some time, it spits a configure error.

How to install wget in cygwin under Windows 7, then?

  • Could you give us the error it gave? – wingedsubmariner Sep 7 '13 at 16:08
  • upvoting post since you get douche bags on superuser that downvote for either no apparent reason or downvote since they know and would rather not share the answer/solution – CybeX Sep 17 '15 at 12:44
4

A little bit late..but a lot has changed since:

(Win7)

  1. make sure you have the latest installer - setup-x86_64.exe, if not, dowload the latest here cygwin.com
  2. run the exe file you downloaded
  3. Installation process definitions (walk-through):
    • install from internet
    • Root Directory (if you had previous installation, keep the same path)
    • All Users (Recommended)
    • Local Package Directory (if you had previous installation, keep the same path)
    • choose connection type - usually 'direct'
    • choose download site
    • at this stage it will download a setup package
    • choose additional packages by clicking 'View' drop-down as 'Not installed'
    • 'Search' text-box type 'wget'
    • change 'skip' by clicking the icon next to it and it will display the version umber to be installed and the 'Bin' check box will be checked
    • check the 'Src?' check box if you wish to get the source code as well
    • click next after choosing all the new packages to be installed
  4. be patient as it might take some time....

good luck

| improve this answer | |
3

wget is also available as a Cygwin package, so you could just install it using the Cygwin installer. As of this writing, the latest version available is wget-1.13.4.

If you just want to use wget, using the Cygwin package is easier than compiling it yourself. However, compiling from source should also work. If configure complains, then most likely some dependency (such as a library) is missing.

| improve this answer | |
  • Yes I installed it as a cygwin package, It is working Problem solved Many Thanks wingedsubmariner and sleske – Protan Sep 9 '13 at 21:52
0

You could use gnuwin too. It works fine, in cygwin and on basic windows cmd.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.