I'm attempting to install Linux Mint 15 entirely within LVM (in four separate LVM logical volumes:

  • /
  • /boot
  • /home
  • swap

I've set up the LVM configuration by booting into the Mint 15 Live environment from a USB key. The LVM and Mint install is going on a 64GB dedicated SSD (The machine also has a 128GB SSD holding Windows and a 2TB HDD for data).

On the 64GB SSD I first created a single Linux LVM partition (sdc1) on the entire disk:

sudo fdisk /dev/sdc

The within fdisk I selected the following:

  • n # Create a new partition
  • p # Make it primary
  • 1 # Partition number
  • # Start (default)
  • # End (default, i.e. the whole disk)
  • t # Change partition type
  • 8e # 8e = Linux LVM
  • w # write partition table to disk and exit

I then did all the necessary pvcreate / vgcreate / lvcreate commands and activated the volume group and formatted /, /boot and /home logical volumes as ext4 and did mkswap on the swap logical volume.

When I reached the partition step in the Mint 15 installation process I saw the screen as shown in the three photos below.

Each of these three pictures shows (in the dropdown at the bottom of the image) three different choices I have tried for the bootloader installation. All three of them has the same result: the BIOS cannot find anything bootable when I select the physical drive (i.e. the 64GB Sandisk SSD, device sdc) as the boot device.

First choice of location for bootloader installation

Second choice of location for bootloader installation

Third choice of location for bootloader installation

If not in any of these three locations, where should I be installing the bootloader in order to make this installation bootable?

Update 1

It seems like this was caused because I booted the Mint 15 live USB key in UEFI mode and therefore it tried to install Mint 15 for UEFI boot while my system already had Windows 7 installed using legacy BIOS boot.

The UEFI BIOS had the option to force UEFI boot, force legacy boot or an option for 'both UEFI and legacy boot' however it seems that it wouldn't boot Mint 15 when installed by booting the live USB via UEFI whether I left the UEFI bios setting at 'both UEFI and legacy boot' or 'force UEFI boot'. In addition it wouldn't boot Windows 7 anymore if I set it to 'force UEFI boot'.

So I wonder, is it impossible then to have two OSs on one system with one booting via UEFI and the other via legacy BIOS? If this is the case what is the point of the option in the UEFI bios to support 'both legacy and UEFI' boot?

In the end I booted the live USB in legacy mode and then when I installed Mint 15, with a grub_bios partition to overcome the combination of a disk using GPT (instead of MBR) with legacy bios (see https://askubuntu.com/questions/132843/why-do-i-need-to-create-a-bios-grub-partition-when-i-install-12-04 )I could get to the grub 2.0 menu and choose whether to boot Windows 7 or the Mint 15 install, which worked. This change brought with it the next problem I'm going to have to solve though! When I boot the machine to Win 7 the display output, as always, (BIOS and Windows 7) comes from the dedicated Nvidia Graphics Card in the machine, not from the motherboard output for the integrated graphics in the CPU. When I boot the Mint 15 live USB in UEFI mode this stays the same, BIOS and Mint 15 OS display from the Nvidia Card. When I boot the live USB in legacy mode, the BIOS displays from the Nvidia Card, but after that the OS displays from the motherboard output for the integrated GPU and not from the Nvidia card and this behavior persists with the Mint 15 installed on the SSD also.


You should install /boot partition outside of LVM, and tell grub to put its files there (and its bootloader part in MBR, if it asks).

That is, create smallish /dev/sdc1 as type 82 and put /boot on it, and then create /dev/sdc2 as type 8e and put LVM and other partitions on it.

  • Hi, I want to install everything including boot inside LVM. This is possible with GRUB 2.0 and Mint 15. – Paul Caheny Sep 11 '13 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.