I'm trying to use Chromecast in Canada and it works well. The only problem is that I'd like to use a custom DNS service which gives me access to Netflix content from other countries. This is however not working as Chromecast has hardcoded DNS rules ( and,

What I'd like to do is add some custom rules in my Netgear router that somehow redirect those DNS queries to a DNS server of my choosing. I see that some people have been successful in doing this with tomato routers. See here.

Does anyone have an idea of how I could accomplish this on a Netgear router? I've enabled telnet access but it doesn't seem to use iptables for route configuration. The router is a WNDR3400v1.


Your Netgear router probably supports Dynamic DNS, although I don't think this will override a directed DNS query. My guess is that it will only work for URLs, but ensure that you have the latest firmware.

As regarding a more evolved firmware, the WNDR3400 is supported by DD-WRT, although the WNDR3400v1 is not specifically mentioned. Redirecting DNS using DD-WRT is described in these articles :

Setting Up UnoDNS for Chromecast (Requires DD-WRT Router)
Redirect Domains and DNS using DD-WRT.

Your router also seems to be vaguely supported by OpenWRT.

If you decide to replace the firmware, ensure that you have downloaded your current Netgear firmware and the tool for its reinstallation even if the router is bricked (I don't remember the name of this utility, but I have done this in the past for a Netgear router). I am not sure that Factory Reset will function correctly if you have replaced the firmware, but this should be your first recovery option if the router is bricked.

  • DD-WRT looks promising. I'll give it a try and confirm that this is the answer. WNDR3400v1 is actually the only version that's officially supported. See here: dd-wrt.com/wiki/index.php/Netgear_WNDR3400 – srmark Sep 12 '13 at 14:47
  • Yup, DD-WRT worked perfectly. This reply was exactly what I was missing since I didn't realize DD-WRT worked on my router. I used the following command to get Chromecast working: iptables -I PREROUTING -t nat -p udp -s <chromecast IP> --dport 53 -j DNAT --to-destination <dns IP> – srmark Sep 14 '13 at 22:56
  • The previous command sometimes gave me problems. The following instructions proved more reliable: help.unotelly.com/support/solutions/articles/… – srmark Sep 24 '13 at 2:10
  • I added your link to the answer. – harrymc Sep 24 '13 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.