I run Windows 7 and I've been getting strange errors from different applications, for example attempting to uninstall VMware Workstation causes the following error:

"Error in the lua script: [string "-------------------------------------------..."]:785: attempt to call global 'ReadRegistry' (a nil value)"

When I attempt to run Process Explorer (which has always worked perfectly) I get the error "Unable to extract 64-bit image. Run Process Explorer from a writeable directory." even though I've tried it in multiple directories I have write permissions to. Only when I launch it as an Administrator will it run correctly.

I believe it may be due to the environment variables as I added an extra path to my "path" variable to allow me to execute easily in cmd from any folder but I've since not only removed it but performed a System Restore and I'm still getting the same errors.

Here's the PATH variable for the system:

C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\GNU\GnuPG\pub;C:\Program Files (x86)\Nmap

and here's the user TEMP variable:


Are these errors caused by my editing of the environment variables or is there another problem?

EDIT: I think I've found the problem, I used Process Monitor to see what was going on and it appears that nothing can write to my Local Temp folder. Here is the result when it's run as a normal user:

enter image description here

But when run as admin it succeeds:

enter image description here

The main problem is I can't see anything wrong with the permissions of my temp folder, it seems that Everyone has read and write access:

enter image description here

I've also got the full Process Monitor logs for both launching as a user and admin if they would help at all.

  • 1
    I don't see an error.
    – Ramhound
    Sep 8 '13 at 3:12
  • Thanks for checking, but it seems that all of these applications started randomly failing around the same time as I modified the PATH variable. Unless there's another reason why different applications are experiencing errors. Sep 8 '13 at 3:25
  • 1
    perhaps as a troubleshoot or workaround you could try to create another user account and see if that has those problems.
    – barlop
    Sep 8 '13 at 3:39
  • I dont know what it means, but it was mentioned that the "users" path is added to the global path. (I dont have users). could it be something that were not seeing here? (assuming that was even the problem)
    – Psycogeek
    Sep 8 '13 at 3:46
  • @Psycogeek That doesn't sound like anything to do with it. I think you may mean along the lines of the users environment variables vs the system environment variables. and I vaguely recall that if you have "path" defined in the users section, then it gets appended to path in the system section.. but I wouldn't have path defined in the users section and anyhow it's nothing to do with it
    – barlop
    Sep 8 '13 at 3:49

I seem to have found the solution, somehow the permissions for my Temp folder were changed so I no longer had full control. Now that I've added myself back as having full control I'm no longer having the errors from Process Explorer.


If a software restriction policy is set to prevent exes from running in folders like AppData\Local\Temp, this error will also occur. In this case an unrestricted path rule can be set in Group Policy as

Local Computer Policy\Computer Configuration\Windows Settings\Security Settings\Software Restriction Policies\Additional Rules\C:\Users\Arron\AppData\Local\Temp\procexp64.exe

A reboot should not be necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.