3

My setup is like this:

  • I have two routers (R1 and R2) at home.
  • R1 is used as a private Ethernet network that connects all my personal devices, such as printer, external HDD, etc. It's not connected to the Internet.
  • R2 is connected to the Internet and serves to other devices such as laptop, mobile devices, gaming console, TV, etc.
  • My Windows 8 laptop is connected to both - R1 via Ethernet and R2 via Wi-Fi.

Now, I cannot access the Internet on this laptop. Windows gives preference to Ethernet and try to connect to the Internet using this. I want Windows to connect to the Internet using the R2 Wi-Fi connection.

  • please paste out the route information: route -n. Usually it's caused by default routing information which should be that from R2. is there a DHCP service in your R1? – shawmzhu Sep 8 '13 at 23:41
  • It is safe to post complete route information publicly here? – matrix Sep 10 '13 at 17:48
  • 1
    understood. In most cases, the last accepted DHCP offer wins which will update your route, DNS and ip address. for example, if your ethernet get DHCP offer from R1 later than wifi device from R2, the default gateway will be R1 which means you can't access internet. So you can try to disable wifi device, then enable it after ethernet get ip address. – shawmzhu Sep 11 '13 at 0:17
  • @shawnzhu, cool. It worked. I switched off wifi (my laptop has a hardware button) and then connected Ethernet. Waited until it identified the network and showed no internet access (If you don't wait, it won't work). Then I switched on wifi. The symbol on the system tray changed to wifi and I can access internet. – matrix Sep 22 '13 at 14:03
  • @shawnzhu, can you post your comment in answers so that I can mark it as answered. This will help other users. – matrix Sep 22 '13 at 14:05
1

In most cases, the last accepted DHCP offer wins, which will update your route, DNS and IP address. For example, if your Ethernet gets a DHCP offer from R1 later than the Wi-Fi device from R2, the default gateway will be R1 which means you can't access the Internet. So you can try to disable the Wi-Fi device and then enable it after Ethernet gets an IP address.

4

For windows>Control panel > network and sharing >adapter settings > Right click the network you want to prioritize >properties> seelect TCP-IP4>Advanced> Click Automatic metric > Set to 1,2,3 etc to give priority :: De-prioritize other networks if required.

2

Configure the Ethernet connection with a static IP address and no gateway. Use DHCP for the wireless connection. Make sure the subnets for R1 and R2 are different.

0

You can change the order of connection priority in Windows settings:

  1. Open the Control Panel
  2. Click 'Network and Internet'
  3. Click 'Network And Sharing Center'
  4. From the left side, click 'Change Adapter Settings'
  5. On the "Network Connections" window, press the Alt key on your keyboard to being up the menu bar
  6. Click the "Advanced" menu and then "Advanced Settings"
  7. In the "Advanced Settings" window you will see the "Adapters and Bindings" tab and under "Connections" you will see the order they are in. You can use the arrows to the side to move the connection priority up and down.
  • This didn't work out. My order (from top) is Wifi >> Ethernet >> [Remote Access Connection]. I tried by changing the position of wifi and ethernet without any luck. – matrix Sep 10 '13 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.